Reloading the page in print preview uses the wrong media type (screen) style sheet

RESOLVED WORKSFORME

Status

()

defect
--
major
RESOLVED WORKSFORME
16 years ago
a month ago

People

(Reporter: daniele, Assigned: saari)

Tracking

({regression})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211


I have a page with two style sheets, one of them for printed media.

<link rel="STYLESHEET" type="text/css" media="screen"href="/css/admin.css" />
<link rel="STYLESHEET" type="text/css" media="print" href="/css/admin_print.css" />

The first time I print preview the page the rendering is correct, if I
right-click on the page and Reload it, the "screen" media style sheet is applied.

Reproducible: Always

Steps to Reproduce:
1. Print preview a page with two style shets (one "screen" and one "print")
2. Right click on the page
3. Select "Reload"
Actual Results:  
The wrong style sheet was applied

Expected Results:  
Apply the "print" media style sheet.
someone broke events so that you even _get_ a context menu.  You should not be
able to get a context menu there and you should not be able to reload the page.
 See also bug 126719
Assignee: rods → saari
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Print Preview → Event Handling
Ever confirmed: true
Keywords: regression
QA Contact: sujay → desale
(Reporter)

Comment 2

16 years ago
I tought that it was a new feature :)

I liked the possibility to browse into the print preview window as a paged media
with "print" media style sheets, maybe it could be a new feature :)

Comment 3

16 years ago
So, this bug appears because you get the contextmenu in the print preview,
shouldn't then the Summary be changed?

Comment 4

16 years ago
dupe of bug 126719 ?

Comment 5

16 years ago
Fixing that bug I guess fixes this one too.
Depends on: 126719

Comment 6

16 years ago
Posted file test case
here's an example of the media type change.  To reproduce:
Load the attachment as a page
Go to Print Preview
Refresh the page

Comment 7

14 years ago
*** Bug 299625 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
F5 no longer works in Print Preview, therefore this does not happen anymore

Build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050703
Firefox/1.0+
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.