RFE: Merge toolbars to avoid wasted space

VERIFIED DUPLICATE of bug 48926

Status

()

Core
XUL
--
enhancement
VERIFIED DUPLICATE of bug 48926
16 years ago
16 years ago

People

(Reporter: Richard Neill, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

There is a lot of wasted space on the right hand side of the File-Edit-View...
toolbar. Could we have the option to use it for some of the things in the
personal toolbar. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



I'm using a laptop - hence I really want to maximise screen use. But I also have
1600x1200. Therefore, the file menu wastes 2/3 of its length. But I don't have
the screen height to waste on a personal toolbar (which I don't need anyway).
I'd like to see this:
--------------------------------------------------------------------------------
File Edit View G. B. T. W. H. Debug QA  [spacer1] X Y Z Bookmarks Home [spacer2]
--------------------------------------------------------------------------------

[spacer1] is such that X,Y,Z,Bookmarks,Home are right-aligned.

[spacer2] moves them far enough from the window control buttons to avoid accidents

X,Y,Z are user controlled links to favourite sites - added via drag/drop.

An alternative would be to allow toolbars to be superimposed (like Konqueror
does). Also, although these could go in the navigation toolbar, being able to
seeing long URLs in full is rather nice - and that space isn't wasted.

Similarly, perhaps the window title bar could also be better utilised? 

Thanks - Moz is great and getting better :-)

Comment 1

16 years ago
Not layout
Assignee: other → jaggernaut
Component: Layout → XP Toolkit/Widgets
QA Contact: ian → jrgm

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 48926 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.