Lost entire mailbox when I upgrade mozilla to 20030216 build

RESOLVED DUPLICATE of bug 170539

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 170539
16 years ago
10 years ago

People

(Reporter: Junghun Yee, Assigned: Bienvenu)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030215
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030216

I was using 20030215 build. When I upgraded it to 20030216 build, I found that
whole mailbox was disappeared. All account data, all inbox data, all localfolder
data seems lost. The files were not deleted; but there was nothing displayed in
Mail application.

It seems like that 0216 build does not comport with older database. I tried to
overwrite files in Mail folder with backuped files over newly created files but
it failed.

Reproducible: Always

Steps to Reproduce:
1. Use Moz Mail build 20030215 and create some text
2. Install 20030216 build
3. Launch Mail app
Actual Results:  
Account info and Mail contents are lost

Expected Results:  
Display its own mailbox content
(Assignee)

Comment 1

16 years ago
actually, you probably lost your prefs.js, or the mail directory setting in your
prefs.js - go look at your prefs.js and see if it still points at your mail
directory - there's a bug in the prefs.js code that can cause it to get
corrupted/lost. It's not a mail database bug, or even a mail bug at all.

Comment 2

15 years ago
*** Bug 194565 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
dupe of bug 170539 or bug 183941?
Keywords: dataloss
(Assignee)

Comment 4

15 years ago
dup'ing

*** This bug has been marked as a duplicate of 170539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.