Status

enhancement
VERIFIED DUPLICATE of bug 196359
16 years ago
14 years ago

People

(Reporter: bleen2, Assigned: sfraser_bugs)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030213 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030213 Chimera/0.6+

For those who have the habit of constantly hitting cmd-w to close windows/tabs
and accidently hitting the "q" instead of the "w."  I'd like to see the
installation of a Prefernece option for users who would want to have a safty net
"Do you want to close Chimera?" message if cmd-q is hit.  And for those users
who don't want to see the message then they don't have to have the preference
selected.

Reproducible: Sometimes

Steps to Reproduce:
hit command-q

Actual Results:  
Chimera quits without a message closing many windows that I didn't want to close
yet.

Expected Results:  
I'd like to see Chimera ask me "Do I want to quit?" message.

Comment 1

16 years ago
I don't think it would be a setting in the Preferences, but if this were to be
implemented it would be done as an "Are you sure you want to quit" dialog with
an optional "Don't show this dialog again" checkbox.

Comment 2

16 years ago
Great idea very user friendly.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Summary: The installation of a Preference option to allow a user to have a "Do you want to quit?" Option → Add pref to confirm quiting.

Comment 3

15 years ago
The preference should be "Confirm Quit always/Confirm Quit when more
than one window is open/Confirm Quit never".

iCAB has this. 

The multiple tab case is already handled.

Comment 4

15 years ago
Re comment 1: It's generally bad UI to have an option like "don't ask again"
without a corresponding pref. What if I change my mind later and *do* want to be
asked?

Re comment 3: How is the multiple-tabs-in-one-window already handled?

In general though, I'm against this pref. If the underlying problem is the loss
of browser state, I'd rather we have an optional
save-state-on-quit-and-restore-on-load, which I belive there's another RFE for.
That, to me, is a more elegant solution to the same underlying problem, and also
a useful feature on top of that (Camino upgrades, restarts/shut-downs, etc).

Comment 5

15 years ago
In answer to Stuart's second point in comment 4, thats the enhancement request
in bug 196359. These aren't quite dupes, but closely related.

Comment 6

14 years ago
I'm marking this bug as a duplicated as this bug is now a duplicated bug 196359.
I will adjust the later to reflect these changes.

*** This bug has been marked as a duplicate of 196359 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.