Closed Bug 193648 Opened 17 years ago Closed 17 years ago

hyperlinks in body do not work at all

Categories

(SeaMonkey :: General, defect, major)

x86
Windows 98
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 102695

People

(Reporter: ron, Assigned: asa)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

Hyperlinks in the body of the page (& all the other interior pages on the site)
do not work at all in Mozilla, yet work to varying degrees in IE5.5, NS4.78

As the web developer I have deactivated style sheets going back to browser
defaults with no joy. I have read the web developer notes & spent hours on this.

Reproducible: Always

Steps to Reproduce:
1.go to www.learn2sail.com.au/adults.html
2.scroll down to Adult Yacht Courses & Adult Dinghy Courses links
3.mouseover any link, attempt to select it

Actual Results:  
nothing

Expected Results:  
displayed link url in status bar, cursor changes from an arrow to a hand,
clicking on one of the links takes you to the url; as these links are modified
by a style sheet they should've also changed color onmouseover & when selected.

I've noted this as a major bug as broken hyperlinks are a major feature of a web
site.
> <div id="point1" STYLE="position:absolute;; z-index: 2; width: 97%; height: 
100%; visibility: visible"> 

This div overlaps the links and click events are trapped by it.  You may want to
make it a width that will be wide enough for the table of links in it, but not
overlap the other text.

Also, in Mozilla and other browser that support position:fixed (Opera,
Konqueror, IE5/Mac, Safari) you may want to use position:fixed for that div
instead of moving it around with JavaScript -- the scrolling will be much smoother.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Thanks for your help, Boris.

> <div id="point1" STYLE="position:absolute;; z-index: 2; width: 97%; height: 
> 100%; visibility: visible"> 

> This div overlaps the links and click events are trapped by it.  You may want to
> make it a width that will be wide enough for the table of links in it, but not
> overlap the other text.

Spot on! Div reduced in width to match the menu width it refers to, now no
longer overlaps the rest of the page so doesn't trap (break) the hyperlinks
(click events).

> Also, in Mozilla and other browser that support position:fixed (Opera,
> Konqueror, IE5/Mac, Safari) you may want to use position:fixed for that div
> instead of moving it around with JavaScript -- the scrolling will be much 
> smoother.

Using position:fixed nailed the floating menu in one location. Reverting to
position:absolute enabled the menu to float as page scrolled up/down, which was
design requirement.
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.