sending signed message with certificate crashes client

RESOLVED EXPIRED

Status

--
critical
RESOLVED EXPIRED
16 years ago
13 years ago

People

(Reporter: Michael.Baraz, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko (latest as of this date)

When sending signed message with certificate but not encrypted causes the client
to crash... I didn't try turning it off as I didn't think of the normal case
until later and had mail to get out.

Reproducible: Always

Steps to Reproduce:
1. Have a valid certificate (I use Thawte, issued by "Personal Freemail RSA
2000.8.30")
2. In Mozilla Mail & Newsgroup Account Settings, Security on account. Turn on
"Digitally sign messages"... (Encryption is Neven by default)
3. Create message and send
4. CRASH!

Actual Results:  
Kills Mozilla application completely, all browser windows, etc.

Expected Results:  
Sign, send message and move to Sent mail.
Do you have a stack trace or a talkback ID ?
Severity: blocker → critical

Comment 2

16 years ago
Using trunk build 20030218 on winxp I ran thru the scenario and it worked for
me.  However my certificate is not a Thawte cert. Does this crash every time?
(Reporter)

Comment 3

16 years ago
Yes, it crashes everytime. I sent 3 messages, in descending levels of
complexity... to the point where my last one was new message, subject=test,
body=test and send.

In all 3 cases it failed the same way.  I was not able to try exhaustive testing
protocols as I had to get work done... including didn't think to try a test
turning off attaching certificate.  It did send Talkback report but I don't see
a history with any incident numbers.

I waited for the beta hoping for a stable version... not many people use
certificates so I am sure this has been test far less than most features.

Hope that helps...

Updated

16 years ago
Blocks: 193931

Comment 4

16 years ago
-- Is the computer you are running Mozilla on running an antivirus program? If
so, please detail what program and what version it is. Temporarily disable the
antivirus program. Then try to reproduce the problem you describe. Does the
problem still occur?

-- Go to Edit | Mail & Newsgroup Account Settings | Outgoing Server (SMTP) and
check "never" on whether to use a secure connection (SSL). Now try to reproduce
the problem. Does it still occur?

-- Go to Edit | Mail & Newsgroup Account Settings. In the appropriate account,
under Copies & Folders, unselect "place a copy in." Now try to reproduce the
problem. Does it still occur? If this works, is this an IMAP account? Are there
many messages in the sent folder?

-- Is the computer behind a firewall? If so, temporarily disable it, or put the
computer directly on the Internet. Can you still reproduce the problem? If not,
what product and version number is the firewall?

-- Delete all your SMTP server entries. Exit Mozilla. Restart Mozilla. Recreate
all your SMTP server entries. Can you still reproduce the problem?

-- Do you have spellchecker installed? If so, disable it or remove it. Does that
solve the problem?

-- Is your profile hosted on a network drive (or NFS mount)? 

If none of these steps work, please attach an SMTP log. The steps for creating
the log can be found here:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Keywords: crash

Comment 5

16 years ago
I am also having this problem.
Signing a message with certificate crashes mozilla when I send.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
uname -a = Linux valiant 2.4.18-18.7.x #1 Wed Nov 13 20:29:30 EST 2002 i686 unknown

The certificate is from XCA (xca.sourceforge.net), but I do not think this has
any bearing on the crash.

The crash occurs before mozilla can copy the message to the Sent folder and
(obviously) before the message is actually sent out.

Turning off the option to digitally sign messages in either the compose window
or the preferences allows the message to be sent.
If the option to digitally sign is on, the crash is immediate. If off, all is well.
Repeatability: Always!

I thought this build was talkback enabled, however, this crashes so hard and
fast that I never get a talkback dialogue box.

Comment 6

16 years ago
Michael Baraz, Buckley Collum: is this bug still an issue for you?  Have you 
tried the suggestions from comment 4, and if so, what were your results?  Have 
you upgraded to 1.3 Final, 1.3.1 or 1.4?
Product: Browser → Seamonkey

Comment 7

14 years ago
Hi all

I'd like to mark this as works for me

I've been using digital certs for signing my email on Win XP for a while now
withough experiencing the problems you have mentioned

Can anyone confirm if they are still having this problem with a recent Mozilla
build?

I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050316

Simon

Updated

14 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.