Closed Bug 193723 Opened 22 years ago Closed 20 years ago

installer fails as non-administrator due to GRE

Categories

(SeaMonkey :: Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bjt23, Assigned: dveditz)

References

Details

(Keywords: verified1.7)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

when you try to install mozilla on windows 2000 or XP (and i presume NT as
well), the installer will complain if you are not an administrator user. 
mozilla should not require this and should install just fine under any directory
writeable by the user.

if you _do_ continue with the install (mozilla1.1), mozilla installs and runs
properly except it has no uninstaller (clicking the "uninstall mozilla" shortcut
in the start menu reports a broken shortcut).

as of now i am unable to get mozilla1.3b to run.  first the installer reports
that GRE cannot be installed due to the lack of an administrator rights, then
proceeds to install mozilla.  running the shortcut or the binary directly gives
no effect (mozilla.exe appears in the task manager process list for about a
second and then disappears, no error message or anything).  i suspect this is an
installer issue as well.

note for both - i'm using the stub/network installer.

i suppose i'm just a unix/linux guy who's used to unpacking moz in my home
directory and having it Just Work[tm] ^_~.

Reproducible: Always

Steps to Reproduce:
-> invalid

Use the .zip build and unzip it.
ftp://komodo.mozilla.org/pub/mozilla/releases/mozilla1.3b/mozilla-win32-1.3b-talkback.zip

Mozilla needs the rights to add registry keys for uninstalling, default browser
settings and GRE location.

Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
v invalid
Status: RESOLVED → VERIFIED
I installed mozilla 1.3/win ( mozilla-win32-1.3-installer.exe ) on win2000pro 
as a non-administrator and have the same problems as reported by Brian, that 
is :
 - Note about not having Admin rights.
 - GRE complaining during install
 - installed mozilla.exe not working
 - uninstall shortcut in start menu not working ( this is because the file 
MozillaUninstall.exe is not installed )

If the install runs , then it should either install a working program, or abort 
with an error message. Not as it currently does, leaving a broken installation.

What Matti said in comment #1 is not true ( "Mozilla needs the rights to add 
registry keys for uninstalling" ) , I can add uninstall entries as a non-admin 
without problems. The trick is to add it into 
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Uninstall instead 
of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

The idea is very simple and actually used by some other ( adminttedly rare ) 
programs. The installer offers two options :
 - install the program for the current user only
 - install the program for all users ( thes can be done only with 
Administrators rights )

The "Current user" method installs stuff in :
 - C:\Documents and Settings\<username>
 - selected program dir
 - HKEY_CURRENT_USER

while the "all users" method installs stuff in :
 - C:\Documents and Settings\All Users
 - selected program dir, like C:\Program Files\mozilla
 - HKEY_LOCAL_MACHINE
( - and, sadly, in C:\WINNT )

The inability to write decent installers is really p*ss*ng me off.
As if it were rocket science to copy a few files ...
( this is about general windows software, not mozilla specifically )
Dupe of bug 101913
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 101913 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago21 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
REOPEN:

The other bug is talking more about accessing "All Users", but the GRE problem
is well described here.

I've been working w/ this problem w/ Mozilla 1.4.1 and Mozilla 1.6 installers.

It does display an error now, but then installs only the Mozilla application
files (C:\Program Files\Mozilla\mozilla), but not the GRE files (C:\Program
Files\Common Files\mozilla.org\GRE).

If the GRE is not installed, the application installer should be giving up w/ an
error. 

If we changed the GRE installer to support user selectable directories, then
asking users to select writable target would be another solution (bug 239105).
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: installer complains when non-administrator user installs in win2k/xp → installer warns non-administrators, but installs application anyhow
-> new
Status: UNCONFIRMED → NEW
Ever confirmed: true
Changing the summary to restrict scope of the bug to cover just the GRE
problems. Marcia reports the uninstall issues working now.

The GRE issues may require changes in which keys Mozilla itself uses at startup.
If that's the case the best short-term answer might be simply to block non-admin
installs rather than leaving the impression it'll work.
Summary: installer warns non-administrators, but installs application anyhow → installer fails as non-administrator due to GRE
Shouln't we be blocking non-admin installs anyway? Even if there were
usable-writeable directories, wouldn't there be system-wide things such as the
registry that would need admin access?
Prior to the GRE all the registry settings we needed could be set under
HKEY_CURRENT_USER if HKEY_LOCAL_MACHINE was inaccessible. If we can't make the
GRE work in this case then yes, we'll just have to block non-admin installs. In
fact, unless fixing the GRE is easy that's almost certainly what we'll do in the
short term (1.7, Firefox 0.9)
If the administrator has already installed the GRE and a regular user, let's
say, wants to install a newer version of Firefox, then what? Will it detect GRE
already exists and let the user install because GRE doesn't need to be installed?
(In reply to comment #12)
> If the administrator has already installed the GRE and a regular user, let's
> say, wants to install a newer version of Firefox

last I checked, firefox didn't use the gre.
(and firefox also uses a completely different installer)
Fine, user wants to install Mozilla 1.8, heh.
Firefox's installer is not /completely/ different, it's a fork of the Mozilla
installer and potentially has the same problems. In this case, though, Firefox
doesn't use the GRE.

But reasonable point, netdragon, it's remotely possible that someone would
install 1.7 and then later a non-admin would install some 1.7-based 3rd party
version (the rumored next Netscape?). I'm not too worried about that scenario
because currently the GRE is only sharable if they're the exact same build date,
which seems unlikely. If we ever get to the idyllic clean embedding future where
a range of GRE's could be shared it might start to matter.
For users with restricted access (non-admins) force a "local" GRE install. For
forced installs skip the restricted access warning and bail-out.
Attachment #148143 - Flags: review?(ssu0262)
Comment on attachment 148143 [details] [diff] [review]
force local GRE for non-admin users

r=ssu
Attachment #148143 - Flags: review?(ssu0262) → review+
Attachment #148143 - Flags: superreview?(dougt)
Attachment #148143 - Flags: approval1.7?
Comment on attachment 148143 [details] [diff] [review]
force local GRE for non-admin users

some installers have the ablity to "install for user" or "install for ALL
users".  Don't you think we should have something like that.  For example, when
we can't get the right permissions to install the GRE globally, I think we
should ask if we want to just install for that user.  I guess what I am asking
for is a dialog: "You do not have permissions to install Mozilla for all users.
 Do you want to continue?" or something like that.

thoughts?
Attachment #148143 - Flags: superreview?(dougt)
By default we install to All Users.  If we can't (normally due to insufficient
permissions) then we prompt on if they would like to continue.

The following dialog prompt is already shown when there isn't enough rights:

Setup has detected that you do not have the appropriate Administrator privileges
to this system.  It is highly recommended that you do not continue with the
installation of Mozilla, or it may not function properly. Would you still like
to continue?
Comment on attachment 148143 [details] [diff] [review]
force local GRE for non-admin users

We allow people to install as a non-admin, we just warn them. Unfortunately GRE
part didn't actually work that way, this fixes it.
Attachment #148143 - Flags: superreview?(dougt)
Attachment #148143 - Flags: superreview?(dougt) → superreview+
Comment on attachment 148143 [details] [diff] [review]
force local GRE for non-admin users

a=asa (on behalf of drivers) for checkin to 1.7
Attachment #148143 - Flags: approval1.7? → approval1.7+
Fix checked in to trunk and 1.7 branch
Status: NEW → RESOLVED
Closed: 21 years ago20 years ago
Keywords: fixed1.7
Resolution: --- → FIXED
QA Contact: bugzilla → benc
I've downloaded 2004-05-12-08 for Windows, and when I install, I still see the
same general behavior.

What is the change in the expected behavior?
not fixed
Status: RESOLVED → REOPENED
Keywords: fixed1.7
Resolution: FIXED → ---
The Restricted Access check was done before the command line was parsed, so the
forced-install flag was always unset. This patch moves the warning messages
down.
Attachment #148722 - Flags: superreview?(bryner)
Attachment #148722 - Flags: review?(ssu0262)
Attachment #148722 - Flags: approval1.7?
Comment on attachment 148722 [details] [diff] [review]
move Restricted Access warning after cmd line parsing

r=ssu
Attachment #148722 - Flags: review?(ssu0262) → review+
Attachment #148722 - Flags: superreview?(bryner) → superreview+
Attachment #148722 - Flags: approval1.8a1?
Comment on attachment 148722 [details] [diff] [review]
move Restricted Access warning after cmd line parsing

a=asa (on behalf of drivers) for checkin to 1.8a1 and 1.7
Attachment #148722 - Flags: approval1.8a1?
Attachment #148722 - Flags: approval1.8a1+
Attachment #148722 - Flags: approval1.7?
Attachment #148722 - Flags: approval1.7+
Fixed for real, 1.8a1 and 1.7 branch
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Keywords: fixed1.7
Resolution: --- → FIXED
V/fixed.

I've installed on a Win 2K system no access to "Common Files" or "Program 
Files", 2004-05-22-09-trunk.

I've installed on a Win 2K system w/ access to "Program Files"
Status: RESOLVED → VERIFIED
Keywords: fixed1.7verified1.7
but no admin rights (20040524/1.7).
will this enable an option to install GRE to the target mozilla directory as
mentioned in bug#238185
*** Bug 238185 has been marked as a duplicate of this bug. ***
for those still having to install GRE by hand in 1.7rc3, these seem the only
registry keys needed to set it up (version number & path need to be edited each
time)

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\GRE\1.7_2004060810]
"GreHome"="D:\\Programs\\Mozilla\\GRE\\1.7_2004060810"
"GreComponentsDir"="D:\\Programs\\Mozilla\\GRE\\1.7_2004060810\\Components"

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\GRE\1.7_2004060810\Uninstall]
"Uninstall Log Folder"="D:\\Programs\\Mozilla\\GRE\\1.7_2004060810\\Uninstall"

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\GRE\1.7_2004060810\Main]
"Install Directory"="D:\\Programs\\Mozilla\\GRE\\1.7_2004060810\\"

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\GRE\1.7_2004060810\Installer]
"PathToExe"="D:\\Programs\\Mozilla\\GRE\\1.7_2004060810\\Setup GRE\\setup.exe"
Use the -greLocal command line option to the installer to force GRE into the
Mozilla directory if you want to override the default.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: