<object> has zero dimensions when percentages are used on page with DOCTYPE specified

RESOLVED DUPLICATE of bug 131065

Status

()

RESOLVED DUPLICATE of bug 131065
16 years ago
16 years ago

People

(Reporter: dsirnapalli, Unassigned)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
-- Test case attached.
-- Its only reproducable in latest commercial branch builds. It works fine in
latest commercial trunk builds and latest mozilla trunk builds.

When you run the test case, the OBJECT element(containing the gif image)should
be scaled by 50% on width and height attributes.

If no DOCTYPE is specified it works fine. It shows up image scaled, but if
DOCTYPE is specified it is not working as intended.
(Reporter)

Comment 1

16 years ago
Created attachment 114726 [details]
Testcase to reproduce the bug
(Reporter)

Updated

16 years ago
QA Contact: ian → dsirnapalli
>
data="http://geckoqa.mcom.com/browser/standards/html_parser/tests/images/trucks.gif"

That's not going to work.  Please post a working testcase? 

Also, this is a duplicate (and probably won't be fixed on the 1.0 branch). 
Please find the bug that originally fixed this on the trunk and mark duplicate.
Whiteboard: DUPEME
(Reporter)

Comment 3

16 years ago
Created attachment 114956 [details]
Image used by the test case
Attachment #114726 - Attachment is obsolete: true
(Reporter)

Comment 4

16 years ago
Created attachment 114957 [details]
Test Case to reproduce the bug
(Reporter)

Comment 5

16 years ago
Working testcase posted, Boris: are you refering to bug 85018, which is fixed
and also verified but that bug is for HMTL pages where no DOCTYPE is specified. 
This bug is for HTML pages where DOCTYPE is specified.
No, this was "fixed" by bug 131065.  Given the regressions that checkin caused
(including crashes and correctness bugs), there's no way that's landing on branch.

*** This bug has been marked as a duplicate of 131065 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: elements (such as images) have zero dimensions when percentages are used on page with DOCTYPE specified → <object> has zero dimensions when percentages are used on page with DOCTYPE specified
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.