the background-color style in a xul:textbox element not rendered correctly

RESOLVED WONTFIX

Status

()

Core
XUL
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: Alex Balyuk, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030206
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030206

In the example below I set the backgroud-color style in the textbox to red.
But in Mozilla 1.3b this textbox is white.
In Mozilla 1.2.1 the example works correctly: the texbox is red.

Reproducible: Always

Steps to Reproduce:
1. Create the file test.xul with the following content:

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>
<window xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
 <textbox style="background-color:red"/>
</window>

2. Open the file "test.xul" in Mozilla 1.2.1.
The background color of the textbox is red.

3. Open the file "test.xul" in Mozilla 1.3b.
The background color of the textbox is white.

Actual Results:  
After step 3 the background color of the textbox is white.

Expected Results:  
After step 3 the background color of the textbox should be red.
Not a DOM problem.
Assignee: jst → hyatt
Component: DOM Style → XP Toolkit/Widgets: XUL
QA Contact: ian → shrir
Looks like more windows-only -moz-appearance stuff (works on Linux).

Comment 4

15 years ago
I'm getting the same issue running Mozilla 1.3.1 on Mandrake Linux 9. 

User-Agent:  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

Comment 5

14 years ago
Problem still exists in Mozilla/Firefox versions that use "Classical"-theme.
Code as presented in the testcase does not modify background-color of a button
or textbox. After switching to "Modern"-Theme background coloring works as expected.
It is not OS-depended as this behaviour can be reproduced also on Linux and Win
XP installations.
Last tested version was Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a5) Gecko/20041122.

Bug #269127 is probably a duplicate of this one.

Comment 6

14 years ago
The Bug exists also in the Linux-Version (Mozilla 1.7.3)

Comment 7

14 years ago
This is due to -moz-appearance. If you set -moz-aapearance: none; then it should
work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 8

14 years ago
You're right. <button label="Farbtest" style="-moz-appearance: none;
background-color: blue"/>
works as expected and turns the background blue.
Sorry, I didn't thought about something like that to be the reason.

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.