<select> accessibility cleanup

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

({access, sec508})

Trunk
x86
Windows XP
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
This bug is for cleaning up accessibility API support of comboboxes and listboxes

1. Remove the extra ROLE_WINDOW object for simplification. This comes at the
request of a screen reader vendor.
2. Fix the states. The ROLE_LIST object wasn't initializing it's state properly,
and was getting random garbage in it.
3. Remove extra files and inheritence that we don't need

It's a large patch, but it mostly just moves code around.
(Assignee)

Comment 1

16 years ago
Created attachment 114747 [details] [diff] [review]
Sorry for the long patch -- mostly moves code around, but also gets rid of ROLE_WINDOW objects
(Assignee)

Updated

16 years ago
Attachment #114747 - Flags: review?(kyle.yuan)
(Assignee)

Comment 2

16 years ago
Kyle, this has been tested, and is ready for your review.

Comment 3

16 years ago
Comment on attachment 114747 [details] [diff] [review]
Sorry for the long patch -- mostly moves code around, but also gets rid of ROLE_WINDOW objects

r=kyle
two indent problems, maybe caused by accidental usages of TAB?

one is in the first comment in nsHTMLSelectAccessible.cpp

+  *  Listbox:
+  *	    - nsHTMLSelectListAccessible

another is in cstr of nsHTMLSelectOptionAccessible,
Attachment #114747 - Flags: review?(kyle.yuan) → review+

Updated

16 years ago
Attachment #114747 - Flags: superreview?(Henry.Jia)

Comment 4

16 years ago
Comment on attachment 114747 [details] [diff] [review]
Sorry for the long patch -- mostly moves code around, but also gets rid of ROLE_WINDOW objects

sr=Henry

Pls pay attention to the indent when checking in.
Attachment #114747 - Flags: superreview?(Henry.Jia) → superreview+
(Assignee)

Comment 5

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.