Could not enter russian character 'ж' in mozilla on sparc/solaris

RESOLVED INVALID

Status

()

Core
Internationalization
--
critical
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Dmitry Afanasiev, Assigned: smontagu)

Tracking

({intl})

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3b) Gecko/20030210 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3b) Gecko/20030210 Phoenix/0.5

Could not enter russian characters 'ж' (small) and 'Ж' (big) in any lastest
versions of mozilla/phoenix/netscape7 on sparc/solaris in ISO8859-5 locale.
This characters automaticaly translated to russian characters 'г' and 'Г' 
and it's wrong. This problem is only on solaris.

Reproducible: Always

Steps to Reproduce:
1. Try to enter this characters in any input windows of browser.
.
Assignee: asa → smontagu
Component: Browser-General → Internationalization
QA Contact: asa → ylong
(Assignee)

Comment 2

15 years ago
Although the problem is with a different character, this looks like the same
kind of issue as bug 127604. Does the problem only occur on text input, or also
in web pages that include this character?

Just to check my understanding, we are talking about the "zhe" character, right?
And the correct rendering is like a Latin X with a vertical bar?

Comment 3

15 years ago
I have verified this problem happens on my environment.

It seems that the problem exists in Solaris X server.
Xsun generates 0x6e7 (GHE) instead. Interesting thing
is that CDE application has no problem with the wrong
keysym.
(Reporter)

Comment 4

15 years ago
To Simon Montagu:
Problem occuped only on text input and only while entering from keyboard.
If I use Copy/Paste - all is ok.
Character displayed correctly.

Yes, this character is "zhe" and rendering like X with a vertical bar
(same as this: }|{ ;)

To Masaki Katakai:
I'm not have this problem on mozilla 0.9.6 and oldest versions.
(Assignee)

Comment 5

15 years ago
*** Bug 201973 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Hello!

Seems that everybody forgot about this nasty bug which still exists!
I verified it in Mozilla 1.5 on solaris.

This bug may be very closely related to the similar bug 157397 with inputting
text which was occurring on AIX, and which was successfully fixed.
http://bugzilla.mozilla.org/show_bug.cgi?id=157397

So please, those who maintain this part of mozilla, take another fresh look
at this bug.

Best,
v.

Comment 7

14 years ago
Hanaki-san, could you look into this problem?

Comment 8

14 years ago
This problem still happens in Mozilla 1.6b on Solaris.

Comment 9

14 years ago
Vladimir, can you build Mozilla? If so, can you try what's done in bug 161581
and let us know the result with 'zhe'?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: intl
(Reporter)

Comment 10

14 years ago
...and this problem still happens in Mozilla 1.7a on Solaris...
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7a) Gecko/20031225 Firebird/0.7+

Comment 11

14 years ago
Are U+0416 (uppercase ZHE) and U+0436 (lowercase ZHE)  only two letters with the
problem? Anyway, it'd be nice if somebody could do what's done in bug 161581? 
(Reporter)

Comment 12

14 years ago
> Are U+0416 (uppercase ZHE) and U+0436 (lowercase ZHE)  only two letters with
> the problem?
Yes.

> Anyway, it'd be nice if somebody could do what's done in bug 161581?
I not see problem reported in bug 161581. On my system "/" and "?" works 
correctly.

Comment 13

14 years ago
Thanks. What I meant is to 

 a) compile mozilla the way described in bug 161581 comment #0
 b) type problematic characters (two characters reported here)
 c) post what you get like this (of course, you have to type two problematic
characters, instead)

Key Press event: gtk string = 'W', keyval = 'W' = 87,
    --> keyCode = 0x0, char code = 'W' (typed SHIFT+W on address bar)
Key Press event: gtk string = '?', keyval = '?' = 63,
    --> keyCode = 0x0, char code = '?' (typed SHIFT+/ on address bar)
(Reporter)

Comment 14

14 years ago
I get this:

Key Press event: gtk string = 'ж', keyval = 'Ч' = 1735,
    --> keyCode = 0x0, char code = '3'
Key Press event: gtk string = 'Ж', keyval = 'ч' = 1767,
    --> keyCode = 0x0, char code = 'r' [shift]

Comment 15

14 years ago
Created attachment 138002 [details] [diff] [review]
patch

Thanks. This may work. This is just applying what's been done for AIX to
Solaris. Why don't you try it and let me know? 

 I wonder whether we have to do it on other platforms as well.

Updated

14 years ago
OS: SunOS → Solaris

Comment 16

14 years ago
Jungshik Shin wrote;
> Created an attachment (id=138002)
> patch
>
> Thanks. This may work. This is just applying what's been done for AIX to
> Solaris. Why don't you try it and let me know? 
>
> I wonder whether we have to do it on other platforms as well. 

Correct me if I am wrong:
IMO this code should not be |#ifdef| per platform - it should check the Xserver
type (or better: The input method should be queired... but I don't remember
anymore whether the protocol provides any "vendor" information) and make the
choice based on that information.

Comment 17

14 years ago
"b" == bugzilla-daemon  writes:

 b> Thanks. This may work. This is just applying what's been done for
 b> AIX to Solaris. Why don't you try it and let me know?

 b>  I wonder whether we have to do it on other platforms as well.

Hi people!

Well, this old and nasty bug is STILL PRESENT in mozilla 1.7 (and in
Firefox 0.9) for Solaris sparc.

Was the proposed patch applied or not?

Is anybody working on it?

This bug was opened about 1.5 years ago. :-(

Best,
v.
(Reporter)

Comment 18

13 years ago
Created attachment 172556 [details] [diff] [review]
patch for solve of bug 193831
(Reporter)

Updated

13 years ago
Severity: normal → critical
(Reporter)

Comment 19

13 years ago
This is not a mozilla bug, this is solaris bug.

To solve it in file /usr/openwin/lib/locale/iso8859-5/Compose change following
lines:
<semicolon>     : "\326"        Cyrillic_ghe
...
<colon>         : "\266"        Cyrillic_GHE

to correct lines:
<semicolon>     : "\326"        Cyrillic_zhe
...
<colon>         : "\266"        Cyrillic_ZHE
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Assignee)

Comment 20

13 years ago
*** Bug 220893 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.