Last Comment Bug 193883 - WMP9 Plugin installed, but 6.4 is used. Add exe names seamonkey.exe/mozilla.exe to ShimInclusionList
: WMP9 Plugin installed, but 6.4 is used. Add exe names seamonkey.exe/mozilla.e...
Status: VERIFIED FIXED
[plugin]
: fixed-seamonkey1.1
Product: SeaMonkey
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: x86 Windows XP
: P3 normal with 9 votes (vote)
: ---
Assigned To: Frank Wein [:mcsmurf]
: installer
:
Mentors:
http://msdn.microsoft.com/archive/en-...
: 167387 196481 230801 237651 244542 280679 320554 320679 351832 357876 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-18 09:46 PST by Chris Gonyea
Modified: 2011-08-05 23:35 PDT (History)
38 users (show)
bugs: blocking‑aviary1.0PR-
bugs: blocking‑aviary1.0-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (766 bytes, patch)
2006-10-30 01:28 PST, Frank Wein [:mcsmurf]
no flags Details | Diff | Splinter Review
Ugly Hack (887 bytes, patch)
2006-10-31 12:08 PST, Frank Wein [:mcsmurf]
dveditz: review+
dveditz: superreview+
neil: approval‑seamonkey1.1+
Details | Diff | Splinter Review
sup yaollz, just put together a simple .reg file for users who are having issues, take care :) (208 bytes, patch)
2007-01-03 02:12 PST, aditya
no flags Details | Diff | Splinter Review

Description Chris Gonyea 2003-02-18 09:46:49 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

When someone installs Windows Media Player 9 with Netscape 7.01 installed on the
system, all sites that use the embedded control report that the version 9
control is being used. However, there is a <a
href="http://www.mozillazine.org/forums/viewtopic.php?t=5989">discussion</a>
over at MozillaZine's Phoenix forums where a number of us noticed that both the
latest Mozilla nightlies, Mozilla 1.0.2, and Phoenix 0.5 (plus nightlies) all
use the Windows Media Player 6.4 control instead, even if Windows Media Player 9
is installed. Since the version 9 control is used in Netscape 7.01 correctly,
there must be some kind of fix in 7.01 that didn't get implimented in Mozilla.
Checked the plugin DLL's and they all appear to be the same in Mozilla/Phoenix's
directories as the ones in Netscape's, but somehow the 6.4 control is used
instead. Can this be fixed? 

Reproducible: Always

Steps to Reproduce:
1. Go to a web site that uses the embedded Windows Media Player control with
either a Mozilla build or Phoenix.
2. When the control is launched, right click the control and click "About"
3. Version says 6.4
4. Go to the same site with Netscape 7.01 and repeat all steps.
5. Version will say 9

Actual Results:  
Audio or video play fine, but using the 6.4 control. On sites that use Multiple
Bitrates, the lowest bitrate stream is used since the 6.4 control and not the 9
control is being used.

Expected Results:  
Mozilla should launch the 9.0 control.
Comment 1 Mark Perris 2003-02-19 09:43:56 PST
i can confirm this too, i have the same results with the applications mentioned
above.
Comment 2 Peter Lubczynski 2003-02-19 10:51:18 PST
testcase?

Can someone run regmon and filemon to see what gets changed by the WMP9 installer?
Comment 3 Mark Perris 2003-02-19 11:26:51 PST
Demonstration URL:
This is MS's refernce cross-platform media player embedding code, so chances are
most sites will follow this implementation.

http://msdn.microsoft.com/downloads/samples/internet/default.asp?url=/downloads/samples/internet/imedia/netshow/crossbrowserembed/default.asp

Select 'demo' from the content pane of that page to open the window containing
the media player.
Comment 4 Doron Rosenberg (IBM) 2003-02-20 17:03:21 PST
Peter - does your sweeping code perhaps need to be updated, since I think there
are some new files for wmp9?
Comment 5 Peter Lubczynski 2003-02-21 10:21:24 PST
This is really weird - my Netscape trunk build seems to choose WMP 9 but my
debug mozilla build is choosing the old one. I have identical copies of
npdsplay.dll and I even changed my user agent string. There is something else
going on here that needs more investigation. Not sure why only Netscape works.
Comment 6 Peter Lubczynski 2003-02-25 15:51:01 PST
*** Bug 167387 has been marked as a duplicate of this bug. ***
Comment 7 Michael Hendy (Hendikins) 2003-03-05 17:08:36 PST
It's got nothing to do with plugin sweeping or the WMP installation routine
(Install WMP9 then a Netscape build and a Mozilla build, and we still have the
same problem).
Comment 8 Matthias Versen [:Matti] 2003-03-08 16:33:28 PST
*** Bug 196481 has been marked as a duplicate of this bug. ***
Comment 9 Matthias Versen [:Matti] 2003-03-08 18:08:01 PST
*** Bug 196481 has been marked as a duplicate of this bug. ***
Comment 10 Doron Rosenberg (IBM) 2003-03-09 11:00:51 PST
nominating for topembed, this could hit embeddors, and a lot of new wmp content
needs wmp9.

this may be evangelism aruner.
Comment 11 J. Gatellier 2003-03-10 06:54:53 PST
It's only a browser identification problem by WMP. Rename mozilla.exe or
phoenix.exe to netscape.exe or netscp.exe and Windows Media Player 9 will work
fine. 
Comment 12 Peter Lubczynski 2003-03-10 10:03:27 PST
yup, confirming that simply running mozilla as netscape.exe uses WMP 9. Although
this is not a problem for Netscape, it will effect embedders as it happens in
mfcembed.
Comment 13 Judson Valeski 2003-03-10 15:13:42 PST
plussing for topembed and over to arun.
Comment 14 Arun Ranganathan 2003-03-10 15:44:35 PST
Changing component to evangelism.
Comment 15 Walter K. 2003-03-11 00:54:59 PST
After suspecting a registry setting or two as a culprit, and poking around for a
few minutes, I think I found solution for this bug. For me, it worked in both
Phoenix 0.5 and Mozilla 1.3 release candidate.

I've tested at
http://msdn.microsoft.com/downloads/samples/internet/imedia/netshow/crossbrowserembed/demo.htm
and at another site, and both of them showed WMP 9 plugin. Though Phoenix
crashed afterwards, I think that is a separate issue.

The fix is to add executable names, i. e. mozilla.exe and phoenix.exe, as keys
under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ShimInclusionList key in
the Windows registry. BTW, Netscape’s and aol's browsers appear there already.
Comment 16 Frederic Bezies 2003-03-11 01:08:13 PST
Thanks for the tip in comment #15 :-)

It is working without problems.
Comment 17 Mark Perris 2003-03-11 04:43:01 PST
could a possible resolution for this bug be making the mozilla installer add
these keys?
Comment 18 timeless 2003-03-11 07:19:28 PST
traditionally the mozilla installer is not used for this stuff, among other
reasons there's no guarantee that the user will actually run it. also what
happens if the user renames mozilla to foop? then mozilla is on shimexclusion
and foop isn't and the problem persists.

peterl: i'd suggest that plugins fix this internally by trying to add the key
for the current app name when it first uses WMP.

Note: making microsoft add each mozilla derivative name to this list isn't
practical.
1. it's slow, since it requires waiting for a new release of WMP9 to saturate
the market
2. there are any number of app names that a gecko might have.

We should contact microsoft directly and find out if there's some call we can
make which is functionally equivalent to being on that list.
Comment 19 Peter Lubczynski 2003-03-11 10:38:26 PST
We should try to understand why they use this browser whitelist in the first
place before hacking around it. Also, why can't they use NPN_UserAgent and sniff
for Gecko like other plugins do?
Comment 20 Walter K. 2003-03-11 14:41:24 PST
I fully agree with timeless that adding keys to WMP registry is not the best
solution. Furthermore, IE does not appear as one of the *included* applications,
but it works nevertheless. So, there must be a different way of making WMP 9
working with an application.

Said all of the above, exe_name_as_a_key_under_ShimInclusionList *is* the way
Netscape 7 works. And that was done by Microsoft itself. Although, there is
absolutely no documentation for ShimInclusionList on MSDN or google.

I do not claim to know much about inner workings of mozilla, but the most
logical place to setup correct key(s) is during the first run of a mozilla-based
app. Or maybe the same place where extension registration is taking place?
Comment 21 Mgz 2003-03-31 16:24:54 PST
from Sébastien Delahaye, dev of Phoenix Installer
[quote]Forget my previous message. I removed the key from the installer, 
because it causes Phoenix to crash on exit if wmp9's been used by Phoenix 
during the browsing session.
[/quote]

but I tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) 
Gecko/20030328 Phoenix/0.5 and everything is OK .

My test page http://www.yukumi.net/te.html
Comment 22 Michael Hendy (Hendikins) 2003-04-13 02:52:33 PDT
Filed bug 201843 for crash on exit when using WMP9 control.
Comment 23 Michael Buckland 2003-05-05 13:15:30 PDT
Discussed in bug triage.  Topembed minusing.
Comment 24 Bryan 2003-05-07 19:54:54 PDT
Hi,
If you delete the windows media player 6.4 form your system it will use windows 
mieda player nine.
Comment 25 Steffen Wilberg 2003-05-16 03:17:16 PDT
As Walter said in comment 20, Internet Explorer does not need to be in
ShimInclusionList. But this does not necessarily mean that there has to be a
different way of making WMV9 working. Maybe IE is just hardcoded in WMP9?

Having the reg added, it works fine for me.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030515 Mozilla
Firebird/0.6.
Comment 26 Nick Bebout 2003-06-12 19:57:11 PDT
SPAM: New Components
Comment 27 Aaron Kaluszka 2003-06-13 08:32:21 PDT
Why did you change the components?
Comment 28 Bob Clary [:bc:] 2003-06-13 09:14:33 PDT
because we are reorganizing the tech evangelism product. for more info see
http://www.mozilla.org/projects/tech-evangelism/ or come to #evangelism.
Comment 29 Aaron Kaluszka 2003-06-13 09:39:03 PDT
I still don't see how this is evangelism.  Are we supposed to get Microsoft to
change the way WMP9 works?  If so, nobody has commented to that effect, unless
that's what comment #19 was about.  Otherwise, evangelism to M$ doesn't seem to
be the best solution (see comment #18), evangelism to developers won't work in
this case, and evangelism to users (ie add this reg key or delete the old
player) is also not feasible.  The solution presented in comment #18 seems the
most reasonable to pursue as soon as the crash bug is fixed.
Comment 30 Chris Gonyea 2003-06-13 12:38:50 PDT
Yeah that's great, ask Microsoft to fix this problem just because we have total
confidence everyone who installs Mozilla will know there is a problem with
properly using the WMP9 control. Even better, everyone will know where to
download the correct WMP version and install it. Also we all know that Microsoft
from the goodness of its heart will fix the Netscape plugin just because it
doesn't recongize any browser except Netscape with a registry hack ;) What are
we going to do, ask Microsoft each time there is a new Mozilla project to add
MOZILLAFIREBIRD.EXE or AwsomeNewBrowser.EXE to the registry?

Wouldn't it be better just to install the correct registry key automatically
during installation and then work with Microsoft to correct this behavior
properly for future WMP versions?
Comment 31 Peter Lubczynski 2003-08-04 12:52:54 PDT
--->installer
Comment 32 amano 2003-08-04 16:20:01 PDT
hmm. I didn't apply any registry fix, but with the MS demo file mentioned above
WMP 9 gets started. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030801 Mozilla
Firebird/0.6.1, Unofficial Aebreahims build.

My WMP is patched to version 9.00.00.3014
Maybe Microsoft fixed that in WMP/WinXP??
Comment 33 Henrik Gemal 2003-08-08 07:25:02 PDT
it's not fixed in WMP9.
btw registry fix is here:
http://gemal.dk/misc/use-windows-media-player9-in-gecko.reg
Comment 34 Chris Gonyea 2003-09-11 18:39:01 PDT
Seems like the latest Firebird builds won't work with the v9 plugin, 6.4 plugin
is used instead, even if the registry patch is used.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827 Mozilla
Firebird/0.6.1+

Expected results (with MozillaFirebird.exe in SlimInclusionList): v9 plugin used
Actual results: v6.4 plugin used
Comment 35 Steffen Wilberg 2003-09-12 01:01:16 PDT
Chris, this still wfm, having the registry patch applied.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030911
Firebird/0.6.1+
Comment 36 Sébastien Delahaye 2003-09-12 08:41:54 PDT
wellander3, please don't remove people from bugs.
Comment 37 Aaron Kaluszka 2003-09-12 08:51:08 PDT
Don't set flags either.
Comment 38 chris hofmann 2003-09-12 20:46:56 PDT
ben, is starting work on firebird installer. adding to cc
Comment 39 Triple7 2003-11-11 11:12:34 PST
WMP 9 works on .WMA files played with browsing with IE, so I'm sure that I have
tha plug-in for WMP. I applied the registry fix to my registry. I added
MOZILLA.EXE to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ShimInclusionList

.WMA files on websites do not play, such as background music on webpages, when I
use Mozilla.
The registry fix did not work for me. :(
Comment 40 Frederic Bezies 2004-01-13 08:59:44 PST
*** Bug 230801 has been marked as a duplicate of this bug. ***
Comment 41 Derwood 2004-01-13 12:10:28 PST
The registry hack only partially worked.  It now uses the WMP9 UI controls, but
the sounds still do not play.
Comment 42 Bryan 2004-01-13 18:40:51 PST
Hi,
It worked for me.
Comment 43 Derwood 2004-01-14 00:40:27 PST
Try this URL and select any ringtone's "play" icon".  At least I get the WMP9 UI
but the sounds won't play.  Works in IE.

http://mww.moviso.com/base.jsp?subNavType=Polyphonic&mainCategoryId=15281
Comment 44 Bryan 2004-01-14 19:09:38 PST
Hi,
Thies seem to rtequire activex to work no wonder it will only work in Internet 
Exploere.
Comment 45 Jonathan David Bloom 2004-01-28 15:28:19 PST
I also can't get this to work. This is my only complaint with Firebird is no WMP
9  Media Control Panel.
Comment 46 Jonathan David Bloom 2004-01-28 15:30:46 PST
BTW if this helps my Firebird is at the followingg.

C:\Program Files\MozillaFirebird
Comment 47 Jonathan David Bloom 2004-02-09 12:18:23 PST
Firefox 0.8 installer does not fix this!!!
Comment 48 Alessandro Minelli 2004-02-09 14:29:23 PST
I think we should add "firebird.exe" and "firefox.exe" to the name in
Shiminclusionlist.....
Comment 49 Jonathan David Bloom 2004-02-09 17:35:43 PST
Adding firefox.exe helped! Finally it's working!
Comment 50 Ben Goodger (use ben at mozilla dot org for email) 2004-02-12 02:22:43 PST
This is now fixed in the Firefox installer. 
Comment 51 R.K.Aa. 2004-03-16 08:50:22 PST
*** Bug 237651 has been marked as a duplicate of this bug. ***
Comment 52 Rob Meredith 2004-04-18 01:42:53 PDT
Windows XP/Mozilla 1.6 - reg hack causes WMP 9.0 to run embedded media, but
still produces behaviour described in comment 43.
Comment 53 Are Årseth 2004-05-25 00:53:49 PDT
*** Bug 244542 has been marked as a duplicate of this bug. ***
Comment 54 Are Årseth 2004-05-25 00:57:06 PDT
The registry workaround works with FireFox 0.8+. However closing a window with
WMP9 takes a long time, (10 seconds) during which FireFox is unresponsive.
Comment 55 PhillC 2004-07-21 06:24:20 PDT
I've applied the registry patch as directed in the Plugin Docs but this problem
still occurs for me. Try the following URL:

http://www.bbcmotiongallery.com/customer/theatre/theatre.jsp?path=/reels/theatre/premiere

I've tried with the following browsers:

Mozilla 1.7
Firefox 0.9

Same results and I can confirm that I have WMP 9.0 installed (works fine with IE6)

The above site (BBC Motion Gallery) requires WMP 7.1 or better for inline
streaming to work.
Comment 56 chris hofmann 2004-07-24 17:33:22 PDT
need to checkout with latest firefox builds on several systems to get to the
bottom of this before shipping
Comment 57 Asa Dotzler [:asa] 2004-07-30 15:26:08 PDT
Seth, can you add this key from comment 15 to our Firefox Windows install
routine so we utilize the new WMP instead of the old one?
Comment 58 Ben Goodger (use ben at mozilla dot org for email) 2004-08-02 17:15:53 PDT
Asa, can you try removing the ShimInclusionList registry key 
("SOFTWARE\\Microsoft\\MediaPlayer\\ShimInclusionList\\firefox.exe")

and do a fresh install with a brunk build and see if this actually happens? I
can't reproduce. 
Comment 59 Steve 2004-09-07 17:45:26 PDT
I applied the registry changes but I am still unable to open content for windows
media player. I have WMP 10 installed and am using Firefox 0.9.3.

Try www.comedycentral.com and try one of their videos.
Comment 60 Marc Winter 2004-09-16 06:41:31 PDT
(This is my first contribution to bugzilla, so please forgive possible mistakes!)

I can confirm this problem. I had Media Player 9 first installed on my current
system, and Mozilla afterwards; then manually copied npdsplay.dll into Mozilla's
plugin folder, and applied the registry patch
http://plugindoc.mozdev.org/resources/wmp9.reg - and still having problems. The
Microsoft test site from comment 3 works fine (if it's supposed to show an
embedded WMP9 control without an actual video playing), but other sites still
claim I have no WMP9 installed, ie.
http://www.comedycentral.com/mp/play.php?reposid=/multimedia/tds/headlines/9031.html

When going to http://www.comedycentral.com/tv_shows/thedailyshowwithjonstewart/
and trying a javascript link to a video, I get a black WMP9 window, but nothing
else happens. Also, now I get a crash message when exiting Mozilla, but only
after trying a link like the latter - not if I have never visited such a link
during my current browser session.

Hope that helps.
Comment 61 Omar 2004-09-19 00:24:06 PDT
(In reply to comment #59)
> I applied the registry changes but I am still unable to open content for windows
> media player. I have WMP 10 installed and am using Firefox 0.9.3.
> 
> Try www.comedycentral.com and try one of their videos.

It's interesting because the Comedy Central (the Daily Show in particular) were
what led me to investigate why WMP9 didn't work with Firefox.  I, like you,
applied the registry changes and nothing happened.  What I did to fix the
problem, however, was to go back into the registry where the changes were made.

The registry patch makes sure firefox.exe is listed in the ShimInclusionList. 
But if you go into the registry, you see above it there is a ShimExclusionList.
 When I removed firefox.exe from the ShimExclusionList, WMP9 (and now WMP10)
started functioning perfectly.

I don't know how firefox.exe ended up in my ShimExclusionList, but the firefox
installer should be programmed to make sure that firefox.exe both in the
ShimInclusionList and removed from the ShimExclusion list.
Comment 62 Marc Winter 2004-09-20 10:15:46 PDT
I checked and I do NOT have anything like Firefox and/or Mozilla in my
ShimExclusionList branch at all - but still have the WMP problem. So this
removal alone doesn't seem to fix it for everyone... :(

OT: Mozilla & Daily Show - so that makes three of us! Well, the Open Source idea
obviously does appeal to the same kind of audience which likes that show... ;)
Comment 63 David S. 2004-09-21 04:48:54 PDT
Add WMP10 to this bug for me. I'm using Mozilla 1.7.3 with j2se 1.4.2_05


what's interesting for me is that if I click on any video links at comedycentral
it says I need wmp9 or higher. Heh! wmp9 and now 10 are installed. Runs fine in
IE of course.

Also the registry key doesn't work at comedyc. or the BBC link posted above
Comment 64 David S. 2004-09-21 05:10:24 PDT
Furthur info:

I installed the Mozilla ActiveX plugin (I know, I know :( but at least it's only
for WMP) and the WMP 10 now plays the comedy central links and the bbc links and
right-clicking shows the version 10 control; last 4 are .3646. 

I don't know if it fixes wmp 9 though.
Comment 65 David S. 2004-09-21 05:32:38 PDT
Well in my previous post, I had that registry key installed but when I removed
it, I now get the 6.4 control instead of 10 at comedyc with no stream but I have
correct version of control at bbc and playability. 

Put the key back in and CCentral now shows correct control version.
Comment 66 Ben Goodger (use ben at mozilla dot org for email) 2004-09-25 23:18:37 PDT
as far as I can tell this works. 
Comment 67 Jim Booth 2004-09-28 07:45:05 PDT
I can confirm that using Mozilla suite Build 20040925 with Windows ME, I was
able to fix the problem simply by manually adding the registry key 

  [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ShimInclusionList\MOZILLA.EXE]

(the same as the patch file in comment #60 does).  I didn't even have to restart
Mozilla.
Comment 68 Derwood 2004-10-20 06:19:57 PDT
The manual workaround works for me with the nightly trunk builds.  Any idea when
this can be added to the installer script?
Comment 69 Derwood 2004-11-24 03:03:58 PST
This applies to WMP10 too.  Summary should be updated.
Comment 70 Dennis Eckhaus 2004-12-06 21:17:39 PST
The WMP9.reg had always worked for me with WMP9 and Mozilla.  I still always get
the WMP6.4 interface with WMP10 and Firefox1.0 installed.  The plugins show up
as there and active.  I even tried the ActiveX for Firefox, but since that made
no difference I uninstalled it.  I also checked the registry and the correct
names are in the ShimInclusionList and are not (properly) in the
ShimExclusionList.  Most sites play files with 6.4 fine, but there are some that
only run correctly using the WMP9 or WMP10 interface.  For example, the 6.4 will
show up and not play the file.  The same site will play the file if the 9 or 10
interface is loaded. 
Comment 71 Dennis Eckhaus 2004-12-08 21:31:29 PST
I ran the downloaded installation file for WMP10 from Microsoft, installing
WMP10 over itself.  Rebooted and made sure to delete appropriate cookies and
cache's.  It now works with the WMP10 embedded player.
Comment 72 alexander 2004-12-15 11:05:01 PST
I'm using Mozilla 1.7.3 and Windows XP with WMP10. I still saw the WMP6.4
controls until added the register entry found in comment #60
( http://plugindoc.mozdev.org/resources/wmp9.reg )

After that, I see the WMP10 cotnrols and everything seems to work fine.
Comment 73 davetest 2005-01-21 23:55:15 PST
(In reply to comment #72)
> I'm using Mozilla 1.7.3 and Windows XP with WMP10. I still saw the WMP6.4
> controls until added the register entry found in comment #60
> ( http://plugindoc.mozdev.org/resources/wmp9.reg )
> 
> After that, I see the WMP10 cotnrols and everything seems to work fine.

I'm using Firefox 1.0 in windows 98 SE.
I've implemented the REG mod mentioned is #60, and reinstalled WMP 9,
but it still doesn't work. 
http://home.comcast.net/~davetest/mplayer_classic_bad_in_firefox.JPG

I'm looking at the BBC News 24 site:
http://news.bbc.co.uk/2/hi/programmes/bbc_news_24/default.stm

I also have FF in windows XP, and it works just fine there.
Dave
Comment 74 Doron Rosenberg (IBM) 2005-01-22 06:48:54 PST
I had the same problem (reg doesn't work, etc), but I then installed WMP 10 and
Mozilla started using it.
Comment 75 M Joyce 2005-01-28 07:08:34 PST
WFM, with no reg fix, no reinstalls no mess

dont know why this is the case.

Mozzila build ID 2005012606
WMP 10.00.00.3646
Comment 76 OstGote! 2005-02-01 10:59:50 PST
*** Bug 280679 has been marked as a duplicate of this bug. ***
Comment 77 Frederic.Cotman 2005-04-06 01:16:05 PDT
I have the problem too every time Mozilla plays an embedded video. With registry
patch I get a crash every time. Does anyone know if there is already a solution
for this problem?
I use Mozilla 1.7.3, WMP 9.00.00.3250 (can't use WMP 10 because I have Windows 2K)
Comment 78 Caleb 2005-04-26 21:45:37 PDT
Since the Mozilla Suite is not really supported, and this bug is applicable to
Firefox aswell, this needs to be reassigned to Firefox.

This is a _very_ easy fix for the installer, only creating one registry key for
Firefox. Opera and other browsers already do this.

Here's a reg key that does something similar
http://plugindoc.mozdev.org/resources/wmp9.reg
Comment 79 Caleb 2005-04-27 02:56:51 PDT
Actually, it's my bad. The firefox installer already sets the correct registry key!
Comment 80 CJ 2005-06-05 10:14:12 PDT
I was having the same problem as others where WMP 6.4(mplayer2.exe) was always
launching instead of WMP10. 
I used REGMON v7.0 to see what Firefox does when I clicked on this link:
http://www.bbcmotiongallery.com/customer/theatre/theatre.jsp?path=/reels/theatre/premiere\

It looks like Firefox was looking in the following registry key to find the
player to use:

HKCR\CLSID\{22D6F312-B0F6-11D0-94AB-0080C74C7E95}\LocalServer32\(Default)

Which defaulted to this player WMP 6.4:
"C:\Program Files\Windows Media Player\mplayer2.exe"	

Once I changed the above registry key to default to 
"C:\Program Files\Windows Media Player\wmplayer.exe" then WMP10 correctly launched.


Note: I did not have WMP10 as my default movie player. I am using Media Player
Classic 
http://sourceforge.net/project/showfiles.php?group_id=82303&package_id=84358as
as my default 
movie player. Maybe this problem depends on which player is the default player.
Comment 81 OstGote! 2005-12-22 21:19:16 PST
*** Bug 320554 has been marked as a duplicate of this bug. ***
Comment 82 Hermann Schwab 2006-02-09 07:36:29 PST
*** Bug 320679 has been marked as a duplicate of this bug. ***
Comment 83 jjning 2006-05-08 16:42:48 PDT
I'm not good with computers, but...

In addition to trying everything else on this site, I decided to poke around in the registry. After changing this, it worked.

HKEY_CLASSES_ROOT\CLSID\{22D6F312-B0F6-11D0-94AB-0080C74C7E95}\InprocServer32\(Default)

Changed it from whatever it was to "E:\WINDOWS\system32\wmpdxm.dll"
Comment 84 D. Rata 2006-07-03 14:39:26 PDT
Running Seamonkey 1.0.2 on Windows XP. The WMP9.reg fix didn't always eliminate the WMP 6.4 controls from appearing on my setup. I eventually determined that this was because Windows sometimes "sees" the Seamonkey process as SEAMON~1.EXE (the executable's DOS short filename equivalent), not SEAMONKEY.EXE. After I added a key called SEAMON~1.EXE to the ShimInclusionList, the problem seemed to disappear.

I recommend adding SEAMON~1.EXE to the list of executables in the WMP9.reg file.
Comment 85 Frank Wein [:mcsmurf] 2006-09-08 16:17:56 PDT
*** Bug 351832 has been marked as a duplicate of this bug. ***
Comment 86 Frank Wein [:mcsmurf] 2006-10-30 01:28:50 PST
Created attachment 244067 [details] [diff] [review]
Patch

Tested locally, seems to work. Firefox did it the same way.
Comment 87 Frank Wein [:mcsmurf] 2006-10-30 02:18:55 PST
*** Bug 357876 has been marked as a duplicate of this bug. ***
Comment 88 Daniel Veditz [:dveditz] 2006-10-30 07:49:52 PST
> Firefox did it the same way.

Firefox isn't going to have the SEAMON~1 problem described in comment 84. Is this fix sufficient for Win9x, or does it work only for Win2k/xp?
Comment 89 Frank Wein [:mcsmurf] 2006-10-30 09:07:47 PST
On Windows 98 I could not find the Windows Media Player plugin at first(npdsplay.dll), I only found DRM WMP plugin. After manually downloading it and putting it in the plugins folder, "seamonkey.exe" in the ShimInclusionList was enough to get the WMP 9 look. I'm not sure about Comment 84, why should on WinXP the plugin use the DOS name of seamonkey.exe? Can someone confirm/deny that "seamonkey.exe" alone on Win2k or WinXP is not enough?
Comment 90 Rafal Likus 2006-10-31 01:18:59 PST
(In reply to comment #89)
> Can someone confirm/deny
> that "seamonkey.exe" alone on Win2k or WinXP is not enough?

I have effect with DOS short filename on Win2k. It hapens (I think) when SeaMonkey is starting after clicking on link, which was received via instant messenger. Starting this way I have in task manager SEAMON~1.EXE. But I am not sure if it hapens everytime.
I cannot reproduce it now on WinXP.
My nephew says he has sometimes the same effect on Win2k. But he do not know when it happens.
Comment 91 Frank Wein [:mcsmurf] 2006-10-31 12:08:29 PST
Created attachment 244224 [details] [diff] [review]
Ugly Hack

For some unknown reason the "Set Default Browser" function in SeaMonkey uses GetShortPathName to get the .exe name of SeaMonkey. That way the default browser name ends up as SEAMON~1.EXE in the registry and other apps (and the default browser in the WinXP start menu) launch SeaMonkey as SEAMON~1.EXE. As long as someone else doesn't have the funny idea of putting other seamonke*.exe files in the installer or the program folder, this should work fine. And even if someone does, then only in the said cases the user will end up with WMP 6.4 UI again. It's not a good patch since it hard codes SEAMON~1.exe, but I don't think it's worth the effort of figuring out the real file name with a special script...trunk will switch to NSIS when suiterunner is used and for SeaMonkey 1.1 this fix should be ok.
Comment 92 Frank Wein [:mcsmurf] 2006-10-31 12:10:53 PST
Ignore the NSIS part in the last comment, the winhooks code in xpfe/ is actually to blame for this. NSIS cannot fix that ;).
Comment 93 Daniel Veditz [:dveditz] 2006-11-27 10:09:36 PST
Comment on attachment 244224 [details] [diff] [review]
Ugly Hack

r/sr=dveditz
Comment 94 Karsten Düsterloh 2006-11-27 11:48:59 PST
Landed on trunk.
Comment 95 Robert Kaiser 2006-11-27 12:02:41 PST
Comment on attachment 244224 [details] [diff] [review]
Ugly Hack

first-a=me for SeaMonkey 1.1, still one needed to go.
Comment 96 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-11-28 11:29:09 PST
mozilla/xpinstall/packager/windows/browser.jst 	1.99.4.4
Comment 97 Benoît 2006-11-28 11:37:00 PST
If the seamon~1.exe bug comes from winhooks, wouldn't it be easier to fix that instead of using this hack?
Comment 98 Frank Wein [:mcsmurf] 2006-11-28 12:58:22 PST
For me fixing the installer was easier.
Comment 99 aditya 2007-01-03 02:12:50 PST
Created attachment 250331 [details] [diff] [review]
sup yaollz, just put together a simple .reg file for users who are having issues, take care :)

since my beta 1.1 was still using the old 6.x i decided to just .reg file patch it

Note You need to log in before you can comment on or make changes to this bug.