The default bug view has changed. See this FAQ.

file:// links won't open

RESOLVED DUPLICATE of bug 84128

Status

Core Graveyard
File Handling
--
major
RESOLVED DUPLICATE of bug 84128
14 years ago
9 months ago

People

(Reporter: David Buehler, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

'file:' links won't open using most normal ways to open a link (left-click,
center-click, right-click->Open Link in New Window, right-click->Open Link in
New Tab)


Reproducible: Always

Steps to Reproduce:
Unfortunately, file:// links are specific to the system you're on, but here's
how I cause this bug on my system...
1. visit my homepage http://rdppsoft.ece.uidaho.edu/~dbuehler
2. On the right are a bunch of "Local File" links.  The top-most one is
file:///home/dbuehler/doc/html/wdghtml40/index.html  (note: some of the later
ones I've converted to http: links so that they will work!)
3. Left-click on any of the file:// links - nothing happens.

Actual Results:  
nothing

Expected Results:  
Mozilla should have visited the file specified in the file:// link

Note: Mozilla 1.0.1 works correctly (it visits the file:// link)

In addition to left-clicking failing to visit the file, center-clicking (I have
mozilla configured so that center button opens link in a new tab, which works
for http:// links) fails to open a new tab and visit the file, right-clicking on
a file:// link (which brings up a pop-up with actions) and selecting "Open Link
in New Window" fails to open a new window and visit the file, and right-clicking
and selecting "Open Link in New Tab" also fails to open a new tab and visit the
file.  In each case nothing happens.  Note however the right-clicking on a
file:// link and selecting "Bookmark this Link" causes a new bookmark to be
created, and visiting that file:// bookmark works correctly.

I'm running Debian GNU/Linux, stable, completely up-to-date.
http:// content cannot link to file:// content for now due to security reasons.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.