browser waits for connection timeout when attempting to retrieve images from ad servers my firewall blocks.

RESOLVED INVALID

Status

()

Core
Networking
--
minor
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: J C, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030105
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030105

This is a feature request.  At this time, the browsers times out when hitting
blocked sites (ad servers).  It would make browsing much smoother (and faster) if
mozilla recognized a "REJECT" from iptables and moved on.  

FYI, I am using reject, not deny.  And I have tried a few --reject-with options
without success (well, the ads are blocked, but mozilla still times out, then
proceeds with processing the page).

Reproducible: Always

Steps to Reproduce:
1. Put something like this in your iptables start script:

# deny ad(s).doubleclick.net DoubleClick Ad requests
iptables -A OUTPUT      -d 204.253.104.0/24     -j LOG --log-prefix
"FIREWALL:OUTPUT-ads "
iptables -A OUTPUT      -d 216.73.86.0/24     -j LOG --log-prefix
"FIREWALL:OUTPUT-ads "
iptables -A OUTPUT      -d 204.253.104.0/24     -j REJECT --reject-with $rej
iptables -A OUTPUT      -d 216.73.86.0/24     -j REJECT --reject-with $rej

where rej=icmp-host-prohibited

2. Hit any site using doubleclick ads.
3. Wait a minute or so for mozilla to time out then finish rendering the page.
Actual Results:  
The page took forever to load.

Expected Results:  
Acknowlege the iptables REJECT and continue rendering without the timeout.

None applicable.

Comment 1

15 years ago
if you're blocking with a firewall, this isn't "Image Blocking"

==> Networking
Assignee: mstoltz → dougt
Component: Image Blocking → Networking
QA Contact: benc

Comment 2

15 years ago
*** Bug 194026 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
A few notes of clarification.  This is my first bug report, so if I sound all
jacked up, I apologize.  I assume a dialog box will be opened informing the
user of the REJECT.  Is it difficult to add a "Don't remind me again" check
box for this?  

I'll take a look at 1.2.1 source (it's what I'm using) and see if I can help,
but my C skills are a little rusty.  

Cooper.

Comment 4

13 years ago
I added an equivalent firewall entry to block www.mozilla.org and tried to load
http://www.mozilla.org/images/mozilla-banner.gif with linux trunk suite
2005041305.  It takes a few second to show an alert dialog that it could not
contact the host.  I get the same behavior with 1.2.1.  I'm guessing that the
difference with doubleclick is that a page might reference multiple images
and/or scripts.

I tried other tools like wget and curl and they also take a few seconds to give
up, so this really looks like a linux networking issue rather than any problem
with networking within Mozilla.

resolving INVALID -- this is not a Mozilla bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.