crash on startup : segv in FcCharSetDestroy

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: bts, Assigned: blizzard)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.0; FreeBSD 4.7-STABLE i386) Opera 6.11  [en]
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.2.1) Gecko/20030218 <developer build>

When I start up mozilla-bin, in crashes with the following traceback:

Program received signal SIGSEGV, Segmentation fault.
0x291d5e6c in FcCharSetDestroy () from /usr/X11R6/lib/libfontconfig.so.1
(gdb) where
#0  0x291d5e6c in FcCharSetDestroy () from /usr/X11R6/lib/libfontconfig.so.1
#1  0x29141814 in nsFontMetricsXft::DoMatch ()
   from /usr/X11R6/lib/mozilla/components/libgfx_gtk.so
#2  0x291412b9 in nsFontMetricsXft::FindFont ()
   from /usr/X11R6/lib/mozilla/components/libgfx_gtk.so
#3  0x291408ba in nsFontMetricsXft::RealizeFont ()
   from /usr/X11R6/lib/mozilla/components/libgfx_gtk.so
#4  0x2913fd43 in nsFontMetricsXft::Init ()
   from /usr/X11R6/lib/mozilla/components/libgfx_gtk.so
#5  0x280b5159 in nsFontCache::GetMetricsFor ()
   from /usr/X11R6/lib/mozilla/libgkgfx.so
#6  0x280b4116 in DeviceContextImpl::GetMetricsFor ()
   from /usr/X11R6/lib/mozilla/libgkgfx.so
#7  0x29685bcc in nsHTMLReflowState::UseComputedHeight ()
   from /usr/X11R6/lib/mozilla/components/libgklayout.so
#8  0x29685d31 in nsHTMLReflowState::CalcLineHeight ()
   from /usr/X11R6/lib/mozilla/components/libgklayout.so
#9  0x29666af3 in nsBlockReflowState::nsBlockReflowState ()
   from /usr/X11R6/lib/mozilla/components/libgklayout.so
#10 0x2965dbf4 in nsBlockFrame::Reflow ()
   from /usr/X11R6/lib/mozilla/components/libgklayout.so
#11 0x2966d4c6 in nsContainerFrame::ReflowChild ()
   from /usr/X11R6/lib/mozilla/components/libgklayout.so
---Type <return> to continue, or q <return> to quit

Reproducible: Always

Steps to Reproduce:

1.type "mozilla"
2. (well, ok, to get the traceback I had to hack the run-mozilla.sh file first)
3.

Actual Results:  
when I just run mozilla it just returns after saying no existing session.
The scripts fail to realize that it failed.

WHen I hacked them to run gdb, that caught the traceback.


Expected Results:  
run . . .

Running FreeBSD 4.7-STABLE #7: Mon Feb 17 16:44:24 EST 2003

(yesterday's FreeBSD, using today's build of mozilla, though with some packages that were built earlier.)

Comment 1

16 years ago
XFT => blizzard
Assignee: asa → blizzard
(Assignee)

Comment 2

16 years ago
We actually call FcCharSetDestroy() three times in that function.  I don't
supposed you could tell me which line it's being called from, could you?
Blocks: 172768
(Reporter)

Comment 3

16 years ago
I did not initially build with -g, but I can rebuild with -g and then I should be able to 
give you a better traceback. 
 
That will take a while but I'll update when I have the results. 
(Reporter)

Comment 4

16 years ago
Somthing went wrong -- I submitted an update a day or two ago via email but it's not 
showing up. 
 
Here it is: 
 
Ok, I am confused and I might need a clue here.  I am building this with  
the FreeBSD ports system and I'm not sure that I understand all this  
but even though I set CFLAGS=-g for the port, and the -g is *in* in the  
compile lines, still gdb complains that it lacks debug info.  So I  
think I'm missing a clue.  Nonetheless, building this way *did* yield a  
different traceback, so perhaps that is of some interest. 
 
(This was easier to generate since I noticed -g flag to mozilla!) 
 
Program received signal SIGSEGV, Segmentation fault. 
0x29c40ea3 in nsHTMLReflowState::UseComputedHeight () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
(gdb) where 
#0  0x29c40ea3 in nsHTMLReflowState::UseComputedHeight () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#1  0x29c41196 in nsHTMLReflowState::UseComputedHeight () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#2  0x29c41279 in nsHTMLReflowState::CalcLineHeight () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#3  0x29c0e690 in nsBlockReflowState::nsBlockReflowState () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#4  0x29bfd9db in nsBlockFrame::Reflow () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#5  0x29c1846f in nsContainerFrame::ReflowChild () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#6  0x29c3bc90 in CanvasFrame::Reflow () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#7  0x29d7efc6 in nsBoxToBlockAdaptor::Reflow () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#8  0x29d7e86a in nsBoxToBlockAdaptor::DoLayout () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#9  0x29d79eb9 in nsBox::Layout () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#10 0x29d69ba4 in nsScrollBoxFrame::DoLayout () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#11 0x29d79eb9 in nsBox::Layout () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#12 0x29d822e8 in nsContainerBox::LayoutChildAt () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#13 0x29c35f17 in nsGfxScrollFrameInner::LayoutBox () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#14 0x29c3634f in nsGfxScrollFrameInner::Layout () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
#15 0x29c35f81 in nsGfxScrollFrame::DoLayout () 
   from /usr/X11R6/lib/mozilla/components/libgklayout.so 
 
(The traceback continues from there but I assume that the remainder is  
not of much interest; please let me know if I am mistaken.) 
 
 
 
Also, here is how the modules are getting built.  Per the man page, the  
ld used on FreeBSD ignores the -g flag, so I don't think that's it.   
And I don't see any "strip" commands, either, though I was not clever  
enough to log the whole building process. 
 
If you have any clues on how to get a more useful traceback I'll be  
happy to hear them. 
 
 
c++ -o TestGtkEmbedChild.o -c -DOSTYPE=\"FreeBSD4\" 
-DOSARCH=\"FreeBSD\"  
-DOJI  -I../../../../dist/include/xpcom  
-I../../../../dist/include/string -I../../../../dist/include/dom  
-I../../../../dist/include/gtkembedmoz -I../../../../dist/include  
-I/usr/ports/www/mozilla/work/mozilla/dist/include/nspr   
-I/usr/local/include -I/usr/local/include -I/usr/local/include   
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include   
-I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion  
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth  
-Wno-ctor-dtor-privacy -Wno-long-long -g -pipe  -DNDEBUG -DTRIMMED  
-ffunction-sections -I/usr/X11R6/include/gtk12  
-I/usr/local/include/glib12 -I/usr/local/include -I/usr/X11R6/include   
-I/usr/X11R6/include  -I/usr/X11R6/include -DMOZILLA_CLIENT -include  
../../../../mozilla-config.h TestGtkEmbedChild.cpp 
 
 
(Reporter)

Comment 5

16 years ago
Ok, this was a building problem with the FreeBSD ports system, not a problem with 
mozilla at all. 
 
I upgraded my fontconfig library, and now everything is working fine. 
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.