non zip/exe downloads are always corrupt

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Joey, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216

when i try to download anything other than a zip file or exe the progress dialog
shows the xfer at -1% the whole time, wont show how much time is remaining, and
the file that is downloaded never works,...ive tried with pdf files, and ptb
files (powertab for guitar)

Reproducible: Always

Steps to Reproduce:
1.right click on link, select save as
2.select path to save to
3.

Actual Results:  
the file downloads, the file size seems to be correct but when i try to open the
file it wont work...i can go directly and get the same file in ie and it works
fine...that sux cuz i hate ie

Expected Results:  
the percentage of the download shoud count from 1% to 100% and the file shoud
open correctly after downloaded

it did the same thing with netscape 7, ive tried about 3 versions of
mozilla...1.02, 1.2 and 1.3b
please help me out i hate having to use ie
i LOVE the tabbed browsing
The page you link to in the "URL" field has a lot of links... could you point to
one specific one this fails with?

What is the downloaded file named?
(Reporter)

Comment 2

16 years ago
EVERY file that is not a zip or exe file will not work
Could you be a little more specific than "will not work"?  And answer my second
question?
(Reporter)

Comment 4

16 years ago
will not work means the file will not open. when i try to run the file in its
program it says it is an unknown file, load aborted
about the second question...NO FILE WILL WORK...take your pick
i tried to get the detonators users guide from nvidia.com which is a pdf file
the ptb files on powertabs.net have to have a special prog to open them 
also .gp3 files from www.mysongbook.com wont work either...
all of these file types are associated with their appropriate progs on my pc btw
> about the second question...NO FILE WILL WORK

That wasn't my question.  My question was two-fold:

1)  What is the name of the file being downloaded _on_the_website_?
2)  What is the name of the file after it has been saved?

Make sure to tell Windows to show file extensions when looking up the answer to
part 2.
(Reporter)

Comment 6

16 years ago
a file i got from mysongbook.com is whitesnake - still of the night.gp3, it
saved as whitesnake - still of the night.gp3 
i have it where windows does show my file extentions (im an old DOS guy) i hafta
i pretty much know my way around a pc thats why this is bugging me so much
would i maybe need to associate the file type gp3 in mozilla itself with its
specified player?
because see i have zips associated with it and like i said earlier zips and
exe's are the only files that will run/open when i get them with mozilla
Ok.. since I'm still having trouble reproducing this, could you please give me
specific step-by-step directions as to what you're doing so I can make sure I do
the same?  Something like:

1)  Go to foo.com
2)  Click "look here"
3)  Shift-click on "look there"
4)  Select the filename "myfile.gps"
5)  Click "OK".

(but obviously with the steps _you_ are using and with the files you're getting).

Comment 8

15 years ago
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc3)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.

Comment 9

15 years ago
WORKSFORME Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030711
-
Reporter, if you see this problem in a recent build of Mozilla, feel free
to return and reopen the bug.

RESOLVING WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.