If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

This build has borked contextual menus; it must be stopped now

RESOLVED DUPLICATE of bug 193799

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 193799
15 years ago
15 years ago

People

(Reporter: carl krall, Assigned: saari (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030218
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030218

Hold-clicking on a link gets me a general menu, not choices like Open In New
Tab, Open In New Window, etc.

After lots of consternated putzing around I realised that I must now hold down
the Control key on my Mac laptop to the get the formerly easily accessable menu.

This is so wrong and stupid. If a user needs the general menu all they have to
do is hold-click or right-click on a non-linked area of the page. 

So in former builds the behavior was easily learned and used, and now the most
commonly used contextual menu is hidden so that an extra key must be pressed to
access it.

Reproducible: Always

Steps to Reproduce:
1. Hold-click on a link, expecting to be able to open it in a new tab.
2.
3.

Actual Results:  
Got a useless (to me) general menu that offers no options relating to the link I
am focused on.

Expected Results:  
Given me the correct contextual menu that is relational to the task at hand,
which is link-handling, and not made me search for a less intuitive and more
complicated way to find the menu I need.

I know that this is the way Apple's guidelines are, but the Jobs team are
clearly sadists, since they issue one-button trackpads and mice with their
computers and then make contextual menus a right-click or control click only.

This was the reason I rarely used Chimera, because one of the main things a user
does with a tabbed browser is open links in new tabs (I use this more than any
other feature of Mozilla), and Chimera made that a PITA by following the Cocoa
guidelines.

So could we please ignore this part of the Apple User mandate, and do it the
smart way?

Otherwise, we part ways here; I'll go back to my 020503 build and wait for a Moz
replacement to come along.

Comment 1

15 years ago
Obviously no blocker.
Dup of bug 193799?
Severity: blocker → normal
Yes

*** This bug has been marked as a duplicate of 193799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.