[DOGFOOD] No error message if smtp server can't be contacted

VERIFIED FIXED in M12

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: akkzilla, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
11/19 commercial build: when I send mail I see no error dialogs so it looks like
everything is fine, but I later discover that nothing got sent.  Turns out that
my smtp server got forgotten about somewhere along the line; when I add one,
mail sending works okay.

Appearing to send mail but not actually sending it is a data loss which could
cause major lost time and frustration for the user, therefore I nominate this
for dogfood.
(Reporter)

Comment 1

19 years ago
Chris has noticed this too.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12

Comment 2

19 years ago
This is definetly a regression. I had this bug once before and we fixed it
so a dialog came up asking you to go edit your account and set up a server.

I'm not sure when this broke but I'll look into it again.

Comment 3

19 years ago
Hmm using my bits, I edited my mail account and deleted the name of my smtp server.


I then sent a message and got the dialog that said: "You have not set up

an smtp server yet...yada yada yada"

Unfortunately, when I hit okay, the compose window dialog was still dismissed.
This is definetly a problem.


Akkana, it sounds like you didn't even see this dialog that I saw though righ?

Updated

19 years ago
QA Contact: lchiang → esther

Updated

19 years ago
Assignee: mscott → rhp
Status: ASSIGNED → NEW

Comment 4

19 years ago
rhp, I'm sending the first of this bug over to you. We're bringing up an error
dialog when sending the message but when I hit okay the compose window is
getting dismissed. I'm pretty sure this used to work back when I added the code
to bring up the dialog in the first place. Adding ducarroz to the cc list to.

If you or JF fix this, send it back to me and I can try to figure out why
Akkana isn't seeing the dialog in the first place.
(Reporter)

Comment 5

19 years ago
Perhaps this is a side-effect of the other bug with modal dialogs not showing up
(I can't read my mail in mozilla today either, because the password dialog never
comes up).  I suggest waiting 'til the dialog bug is fixed before worrying about
this one.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 6

19 years ago
Putting on PDT radar

Updated

19 years ago
Assignee: rhp → ducarroz

Comment 7

19 years ago
(phil) JF, could you take a look at this?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

19 years ago
No problem, I am taking care of it... Thanks for giving me a PDT+ :->
(Assignee)

Updated

19 years ago
Whiteboard: [PDT+] → [PDT+]Should be fixed by 11/26
(Assignee)

Comment 9

19 years ago
Ok, I cannot reproduce the case Akkana reported but I see the problem mscott
has.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+]Should be fixed by 11/26 → [PDT+]
(Assignee)

Comment 10

19 years ago
I have misunderstood akkana problem. It's the same than mscott!
Fixed and checked in.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
Using builds 1999112917m12 on win98 and 1999112908m12 on linux and 1999112910m12
on mac this is fixed per description of scenario.  If no smtp server is given,
the user gets an alert (which is worded so user understands there is a problem
with the server).  When user clicks OK the Compose window it still available and
smpt server can be corrected so existing message can be sent.   However, if
network is not connected it takes up to a minute for the alert to come up, for
Win32 the alert is not the same as when the smpt server is not given (it's a
string ID(hex) alert.  I will verify this bug an log a new one for the slowness
of the alert and incorrect text on win32 when the network is disconnected.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.