Bradesco homebanking security applet won't load

RESOLVED EXPIRED

Status

Core Graveyard
Java: OJI
--
major
RESOLVED EXPIRED
16 years ago
8 years ago

People

(Reporter: Francis Augusto Medeiros, Assigned: Patrick C. Beard)

Tracking

({qawanted})

Trunk
PowerPC
Mac OS X
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

When I enter my account number and branch number at the homepage of my bank, it
opens another window asking for my password. There is a security Applet that
gotta be loaded. Under Mozilla 1.3a, this Applet was loaded normally. Under
1.3b, it says "Applet started", but the word "Aguarde" (wait) doesn't change to
"Entrar" (submit), and a message in Portuguese tells me that the Security Applet
wasn't loaded. Again, it worked pretty well under 1.3a, but not under 1.3b. I'm
using OS X 10.2.4. Does it has something to do with running it's own java
implementation, or the computer's? It seemed that, when Mozilla was using the
implemented Java that comes with MacOS X, things worked. Has this changed?

Thanks a lot in advance!

Reproducible: Always

Steps to Reproduce:
1. Access the URL www.bradesco.com.br
2. Fill in account and branch and digit information
3. 

Actual Results:  
Security Applet doesn't load.

Expected Results:  
Change the word "Aguarde" (wait) into "Entrar" (submit), loging into the bank.
-> Oji
Assignee: idk → joshua.xia
Component: Java-Implemented Plugins → OJI
QA Contact: avm → petersen

Comment 2

16 years ago
MacOS -> beard
Assignee: joshua.xia → beard

Comment 3

16 years ago
Francis, your Steps to Reproduce appear incomplete. After accessing the URL, I
see no form fields in which to enter and account and branch and digit information.
Summary: Under Mozilla 1.3a, the security Applet my homebanking uses would load up, but now, under 1.3b, it won't. → Under Mozilla 1.3a, the security applet my homebanking uses would load, but now, under 1.3b, it won't.
(Reporter)

Comment 4

16 years ago
Greg, 

That was maybe my fault. The page is in Portuguese.
The form is located at the lower side of the window, and the labels are:

Agencia (branch)
Conta (account)

The "Conta" has two fields, a big one for the account number and a smaller one
for a 1-digit number that's part of the account number.

Yours,

Francis
(Reporter)

Comment 5

15 years ago
Well, this bug is present again in Mozilla 1.3. The only browser under MacOS X
that seems to load the Security Applet correctly is Mozilla 1.3a.

I'm giving now more detailed instructions about how to reproduce this bug:

1 - Go to the website www.bradesco.com.br
2 - Locate the fields "Agência" and "Conta", on the lower part of the window.
3 - Under the Agência field, fill in 270
4 - Under the Conta field, fill in 46040
5 - Under the single-digit field, enter 0
6 - Click on the "Entrar" button.
7 - A new window will open, and then the bug will manifest itself: after a
while, under the 1.3a version, the button named "Aguarde" changes to "Entrar",
which allows ppl to log into their accounts. Under the 1.3b and 1.3 versions, it
 says on the status bar that the Applet is loaded, but it doesn't change that
button to "Entrar", which is necessary to allow clients to log in. 
8 - Sometimes, under the 1.3a version, where the applet works, depending on the
java version installed (1.4.1 or inferior), it will require to click on the
"Aguarde" button in order to show up a dialog window saying that the applet is
not loaded, and then the button changes to "Entrar", making it all work. But
after I upgraded to Java 1.4.1, it automatically changes to "Entrar" as soon as
the applet is loaded.

I hope that this has helped.

Yours,

Francis

Comment 6

14 years ago
18 months later...

Does this bug still affect you in Mozilla 1.7 or Firefox 1.0?
(Reporter)

Comment 7

14 years ago
Yes. It's curious that the newest Safari and Java updates made it work corretly under Safari, but Mozilla 
and Firefox don't work well with my homebanking still...

Updated

14 years ago
Keywords: qawanted
Summary: Under Mozilla 1.3a, the security applet my homebanking uses would load, but now, under 1.3b, it won't. → Bradesco homebanking security applet won't load
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Updated

12 years ago
Blocks: 317677

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.