Mozilla installation corrupts current PalmPilot Desktop installation/conduits

RESOLVED DUPLICATE of bug 198035

Status

SeaMonkey
Installer
--
major
RESOLVED DUPLICATE of bug 198035
16 years ago
13 years ago

People

(Reporter: fred muhlenberg, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: workaround is registry edit)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

After installing the Mozilla 1.3beta, I am unable to synchronize my palm pilot.
 In essence, the Mozilla install breaks this working application.

This problem is manifested when attempting to start the Palm desktop.  There
"suddenly" is no user available and I cannot recreate my user name.

HotSync still runs.  Attempts to synchronize hang when trying to synchronizing
my documents.  The Palm pilot says synchronizing Acrobat documents while the
desktop cites synchronizing Documents To Go -- however, the documents to go
application never run.  Normally, when synchronizing , a Documents To Go splash
screen displays.

Installed Palm related applications:
Palm Desktop 4.1
Documents to Go
Acrobat for Palm

This problem also occurs in the Mozilla 1.2.1 installation as well.

Reproducible: Always

Steps to Reproduce:
1. Install Palm OS desktop (4.1)
2. Synchronize Palm data - this establishes a user name for the Palm
3. Install Mozilla 1.3
4a. Start Palm desktop.  A dialog with an empty user list is displayed
requesting "Select a user:"
-or-
4b. Synchronize Palm.  Hangs on Documents To Go.

Actual Results:  
Synchronization hangs waiting for Documents To Go to run.

Expected Results:  
I would expect Mozilla to not alter the operations relating to my Palm pilot
applications such that Documents To Go will still run.

I am not synchronizing my email to the Palm.

The workaround is to uninstall, then reinstall the Palm Desktop and other Palm
desktop applications (Documents to Go, et al).

Comment 1

16 years ago
Please look at bug# 182423 because this issue seems similar and it has been
verified fixed.

Just to clarify, step# 3 installs Mozilla the application (and not the Mozilla
Address Book Palm Installation)?
QA Contact: gbush → nbaca

Comment 2

16 years ago
.
Assignee: dveditz → cavin
Component: Installer: XPI Packages → Address Book
Product: Browser → MailNews
(Reporter)

Comment 3

16 years ago
Clarification:
step# 3 installs Mozilla the application.

Bug #182423, shows similar effect with respect to the Palm Desktop presenting a
"Users" dialog box offering a list of zero users. In my case, I am installing
Mozilla only and I do not link my Palm email and address book to Mozilla.

Also, I was upgrading an existing Mozilla 1.2.1 installation to 1.3b.  Don't
know what would happen if installing a virgin copy of Mozilla.
-Fred
(Reporter)

Comment 4

16 years ago
Two more things:
Reinstalling the Palm desktop restores my ability to sync Palm applications. I
did not uninstall it.

Documents to Go requires a complete cycle of uninstall and install to get this
to work.  When attempting to just reinstall (ie overwrite), an exception was
generated (which in retrospect I should have written down).

Comment 5

16 years ago
Thank you for the clarification. When Mozilla 1.3b is released please try again. 

Comment 6

16 years ago
I have seen this too.  Default installation of Franklin Planner software 7.3 on
Windows 2000 (latest service packs) in my case, which installs some Palm
conduits. After mozilla install, the conduits are screwed up (sorry to not
provide more details, I should've written them down but had to get it working
again), and things like Palm Installer don't look in the same place as they used
to for add-ons.  This happened with the latest mozilla 1.3 install I'm using
now.  I have heard of the same thing with Netscape 6.

Comment 7

16 years ago
I have confirmed that this is a result of the 1.3 (final) install, and what is
happening.

Adding more detail to the symptoms, after attempting to start Palm Desktop,being
presented with an empty user-select dialog, and finding yourself unable to enter
either a known or new userid, upon canceling, a error pops up refeencing the
USERS.DAT file.  To confirm, start HOTSYNC directly, which will then fail with
two mentions of being unable to find USERS.DAT, which is the key to this
problem.  I found the above to be true even after restoring the entire /PALM
directory from a day-old backup tape.

Diagnosis:  During the installation process, the registry key (win98SE2):

My Computer\HKEY_USERS\subpop\Software\U.S. Robotics\Pilot Desktop\Core\Path

is changed from (in this case) C:\PROGRAM FILES\PALM to C:\TEMP\NS_REG , but
never restoredd (if indeed it should have been modified in the first place)
which is obviously in error.  I would venture a guess that this is somehow
connected to the Palm Sync subapplication.

Circumvention: Not known, not discovered.

Recovery:  Edit the above key to contain the actual PATH to the Palm Desktop
executable.

Comment:  You may wish to merge bug 198035 with this bug.  Symptoms appear
identical.

Comment 8

16 years ago
I confirm what William says.  The only difference is that on my system (Windows
98), the registry key is 

HKEY_CURRENT_USER\Software\U.S. Robotics\Pilot Desktop\Core\Path

I'm using Palm Desktop 3.1 and Mozilla 1.3.

Comment 9

15 years ago
I can also confirm what William says with Win2k SP1, Palm Desktop 4.1, Mozilla
1.3 final.

Also, the registry entry was the same as comment #8 and changing the contents
fixed everything.
Reports include v1.2.1, v1.3b, v1.3:
Removing "1.3b" from the summary.

Also, could someone check with a recent build (like v1.4rc3) ?
Summary: 1.3b install corrupts current PalmPilot Desktop installation/conduits → Mozilla installation corrupts current PalmPilot Desktop installation/conduits
(spam sorry)

Changing:
 *(Se) Normal -> Major. (brake other software)
 *(St) Unconfirmed -> New. (after a few confirmations)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

15 years ago
Can't reproduce this with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916
(1.5RC2)
Product: Browser → Seamonkey

Comment 13

13 years ago
Personally switched to Mac OS but my girlfriend hasn't had problems with Palm Desktop and Thunderbird 
lately. This is with the latest (non-nightly) version of Thunderbird. Don't want to install nightlies on her 
system. Can try it on a separate account if needed...

Comment 14

13 years ago
duping as suggested in comment 7

*** This bug has been marked as a duplicate of 198035 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Component: Address Book → Installer
Resolution: --- → DUPLICATE
Whiteboard: workaround is registry edit
You need to log in before you can comment on or make changes to this bug.