command/control-L doesn't really select location after switching tabs after opening new tab

VERIFIED DUPLICATE of bug 177166

Status

VERIFIED DUPLICATE of bug 177166
16 years ago
10 years ago

People

(Reporter: c.pew, Assigned: jag-mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

After opening a new tab by typing a URL in the location bar and pressing
command-enter(Mac) or control-enter(Linux), if I return to the original tab and
press command/control-L it highlights the URL in the location bar as if
selected, but typing acts as if the page were still selected for input. I have
to click in the location bar before it works.



Reproducible: Always

Steps to Reproduce:
1. hit command-L(Mac) or control-L(Linux), enter new URL, hit
command/control-enter to open in new tab.
2. click on tab for original page.
3. hit command/control-L to enter another URL.
4. start typing new URL.

Actual Results:  
At step 3, URL in location bar was highlighted as if selected for replacement,
but when I started typing Mozilla tried to find matching text in the page or
entered text in an input field (if the field had focus before I opened the new tab.)

Expected Results:  
replaced the URL in the location bar with the typed text

same bug occurs on Linux version: Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.3b) Gecko/20030210

Comment 1

16 years ago
I see this too.  I had to load two pages and on the third Ctrl L mozilla started
to search the page instead of typing into the Location box.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030217

*** This bug has been marked as a duplicate of 177166 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 4

16 years ago
If you got here by following a checkin comment for plevent.c, you're really 
looking for bug 194226.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.