Status

Other Applications
Venkman JS Debugger
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Robert Ginda, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
Attached patch fixes the following problems...

ASSERTs in debug builds caused by calling the window.alert, prompt, and confirm
functions from chrome.  Instead, we write our own functions in terms of the
prompt service.

Inability to set any kind of breakpoint in a file loaded from "Open File" or
"Open Web Location".

Adds "Add Watch Expression..." to the context menu of the Watch view.

The patch has been available as an XPI since the 14th.  A regression related to
the new prompt command was discovered and fixed on the 19th.  No other problems
have been found, and of course, the patch doesn't change anything outside of
extensions/venkman.  I'd like to check this in for 1.3 final.
(Assignee)

Comment 1

16 years ago
Created attachment 115018 [details] [diff] [review]
changes for venkman 0.9.48
(Assignee)

Updated

16 years ago
Attachment #115018 - Flags: approval1.3?

Comment 2

16 years ago
Comment on attachment 115018 [details] [diff] [review]
changes for venkman 0.9.48

a=asa (on behalf of drivers) for checkin to 1.3.
Attachment #115018 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 3

16 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
rs verifying these land venkman "0.9.x" bugs -- latest version is now well past
these guys.
Status: RESOLVED → VERIFIED
Product: Core → Other Applications

Updated

13 years ago
Depends on: 327827
You need to log in before you can comment on or make changes to this bug.