Solaris: Crash in COOKIE_SetCookieStringFromHttp

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
P1
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: mats, Assigned: Chris McAfee)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-], URL)

(Reporter)

Description

18 years ago
Loading the URL into build 1999111909 on Sun/Solaris 2.6/sparc gives this crash:
=>[1] PR_ParseTimeString(0x6f722f, 0x1, 0xefffd6fc, 0x0, 0x1, 0x0), at
0xef351578
  [2] cookie_ParseDate__FPc(0x6f722f, 0x3b, 0x6f722f, 0x1, 0x21b160, 0xff0000),
at 0xed9abe08
  [3] COOKIE_SetCookieStringFromHttp__FPcN20(0x4cc340, 0x6f7200, 0x605680,
0xecc4099c, 0x801700, 0xa), at 0xed9a9a24
  [4] AsyncExamineResponse__18nsCookieHTTPNotifyP11nsISupports(0x0, 0x801700,
0x136100, 0xed9ad390, 0x2, 0x0), at 0xed9ad600
  [5] OnHeadersAvailable__13nsHTTPChannel(0x801700, 0xefffd8a8, 0x1, 0x1,
0xefffd8d4, 0xff00), at 0xecc41a04
  [6] FireOnHeadersAvailable__22nsHTTPResponseListener(0x386140, 0xecc48000,
0x20, 0x1, 0x1, 0xef419fcc), at 0xecc43f94
  [7] FinishedResponseHeaders__22nsHTTPResponseListener(0x386140, 0x5fdb08,
0x486, 0xefffda44, 0x170, 0x16c), at 0xecc445b4
  [8]
OnDataAvailable__22nsHTTPResponseListenerP10nsIChannelP11nsISupportsP14nsIInputS
treamUiUi(0x386140, 0x6e3e00, 0x801700, 0x5fdb08, 0x0, 0x5b4), at 0xecc43de8
  [9] HandleEvent__22nsOnDataAvailableEvent(0x4e0840, 0xee33f0fc, 0x64ec0,
0xef746f2c, 0xefffded8, 0xef746f24), at 0xee33f12c
  [10] HandlePLEvent__21nsStreamListenerEventP7PLEvent(0x4c1040, 0xee33e9dc,
0xef746c00, 0xef746f2c, 0xef746c00, 0x1), at 0xee33e9f8
  [11] PL_HandleEvent(0x4c1040, 0x5fe000, 0x48a000, 0x41f014, 0x4e0000, 0x0), at
0xef4e2328
  [12] PL_ProcessPendingEvents(0x97040, 0x48a000, 0x4e0000, 0x41f014, 0x378000,
0x4e0), at 0xef4e22b0
  [13] ProcessPendingEvents__16nsEventQueueImpl(0x64e60, 0xef429e84, 0x35a,
0x378000, 0x378b00, 0x378), at 0xef429e88
  [14] 0xee0f2bb4(0x64e60, 0x7, 0x1, 0xee0f2b98, 0x0, 0x0), at 0xee0f2bb3
  [15] 0xee0f2600(0x23f660, 0x1, 0x23f640, 0xee0f25dc, 0x0, 0x0), at 0xee0f25ff
  [16] 0xef7011bc(0x23f680, 0xefffded8, 0x23f640, 0x378b18, 0x0, 0xefffde48), at
0xef7011bb
  [17] 0xef7029bc(0xef746c00, 0xef746c00, 0xef746c00, 0xef746f2c, 0xefffded8,
0xef746f24), at 0xef7029bb
  [18] 0xef702fcc(0xef746c00, 0xef746c00, 0xef746c00, 0xef746f2c, 0xef746c00,
0x1), at 0xef702fcb
  [19] g_main_run(0x23f6e0, 0xef745800, 0x0, 0xc8, 0xef7ec9c0, 0x17), at
0xef703154
  [20] gtk_main(0x0, 0x64e60, 0x1, 0xee0f30b8, 0xef426a0c, 0x0), at 0xef66f5b4
  [21] Run__10nsAppShell(0xc7580, 0xee0f2eb4, 0xc7580, 0xeee90818, 0x0, 0xffe),
at 0xee0f3024
  [22] Run__17nsAppShellService(0x6efc0, 0xeee7d800, 0x6efc0, 0xedad8398, 0x0,
0xef12a148), at 0xeee7d814
  [23] 0x14e94(0x1, 0xefffe2e4, 0x0, 0x2, 0xffffffff, 0xef7c16e1), at 0x14e93
  [24] main(0x1, 0xefffe2e4, 0xefffe2ec, 0x29a70, 0x0, 0x0), at 0x150d8

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Crash in PR_ParseTimeString → [DOGFOOD]Crash in PR_ParseTimeString
Target Milestone: M12

Comment 1

18 years ago
tever, can you try this on all plaforms: Win32, Mac, and Linux and let us know
results.  Can you reduce this testcase?  Is it only this page?  Thanks!

Comment 2

18 years ago
Jan, I checked the 1119 build on the three platforms you listed and can not
reproduce this one.  I also checked the current builds.  No problems there
either.

Updated

18 years ago
Assignee: morse → mcafee
Status: ASSIGNED → NEW

Comment 3

18 years ago
re-assigning to Chris to check on Sun/Solaris

Updated

18 years ago
Whiteboard: [PDT-]

Comment 4

18 years ago
Putting on PDT- radar.  Not a problem on tier 1 platforms

Updated

18 years ago
Priority: P3 → P1
Target Milestone: M12 → M13

Comment 5

18 years ago
Move to M13.
(Assignee)

Updated

18 years ago
Summary: [DOGFOOD]Crash in PR_ParseTimeString → Solaris: Crash in PR_ParseTimeString
(Assignee)

Comment 6

18 years ago
Works on linux for me, need to check solaris.
I am downgrading this from dogfood status,
argue with me to re-instate.
(Assignee)

Updated

18 years ago
Summary: Solaris: Crash in PR_ParseTimeString → Solaris: Crash in COOKIE_SetCookieStringFromHttp
(Assignee)

Comment 7

18 years ago
resummarizing up the call stack a little
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

18 years ago
This works for me, Solaris 2.6, gcc-2.7.2.3, ultra-1.

Mats, can you try this again and reopen if this is still happening?
(Reporter)

Comment 9

18 years ago
Works for me too (nightly build 1999120210 Sun/Solaris 2.6/sparc).

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 10

18 years ago
Marking as verified.  Working on original system.
You need to log in before you can comment on or make changes to this bug.