Closed Bug 194273 Opened 17 years ago Closed 17 years ago

move to junk folder (or delete) when the user manually marks as junk.

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.4final

People

(Reporter: sspitzer, Assigned: sspitzer)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [adt1])

Attachments

(5 files, 10 obsolete files)

10.63 KB, patch
Details | Diff | Splinter Review
28.13 KB, patch
sspitzer
: review+
sspitzer
: superreview+
sspitzer
: approval1.4+
Details | Diff | Splinter Review
51.37 KB, image/gif
Details
1.99 KB, patch
sspitzer
: review+
sspitzer
: superreview+
sspitzer
: approval1.4+
Details | Diff | Splinter Review
1.06 KB, patch
Details | Diff | Splinter Review
move to junk folder (or delete) when the user manually marks as junk.

See http://www.mozilla.org/mailnews/specs/spam/images/Spam1d.gif
adding dependency on 11035 so it's easier for people to find this bug.
Blocks: 11035
There should be a delay of a few seconds in case the user accidentally marks an
important mail a junk. The delay should be about 5 sec.? user settable?

I user selects to "delete" manually marked mail, then the "Mark as Deleted"
pref, if set, should be respected.
related/equal to bug 180029?
similar but different.  that bug is so if you choose "run jmc manually" it will
move the mail it marks as junk to the junk folder.  this is so if jmc doesn't
mark a message as junk, then when you mark it as junk yourself, it goes away
automatically.  that one, jmc marks it as junk, this one, you mark it as junk.
This is a dangerous feature. Perhaps the junk icon could blink 5 times before
the mail disappears into the (potentially very full) junk folder. A pulsating
yellow outline around the small junk icon in the messages pane would be cool.
or make it a pref - it drives me NUTS that I have to hit junk-delete to delete a
message. 

The only thing that makes this really dangerous is that a good message can get
mistakenly marked as junk.. and then since its no longer on-screen, the user
can't easily undo that.. but wait! There is an "Undo" file menu item.. that
solves the problem for at least some of the users.

How about a confirmation dialog "Are you sure you want to mark this message as
Junk" (someone else can write the copy) with one of those "Don't show this to me
again" checkboxes?

Plan is make it a pref, Move, Delete or Off completely.
http://www.mozilla.org/mailnews/specs/spam/#JMC
Mail triage team: nsbeta1+/adt2
Keywords: nsbeta1nsbeta1+
Whiteboard: [adt2]
accepting, beta (or alpha), but most likely beta.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4beta
Target Milestone: mozilla1.4beta → mozilla1.4alpha
OS: Windows 2000 → All
Hardware: PC → All
FWIW, my preference (no pun intended) would be for a button (make the Junk
button a drop down?) and/or a menu (including context) item to "Move all junk to
Junk folder", where 'Junk folder' is the one defined in the JMC. My reasons are,
as mentioned in other comments, the danger of accidently marking a good mail as
junk and not noticing because it disappears.

Lets be realistic here; this is only an issue in the early days of training JMC,
once it's up and running (mine is now ~90% accurate) the number of messages
involved is small so a couple of extra mouse clicks isn't a major usability issue.

Just my €0.02 of course.



To present the flipside: I average about 40 spams a day at work, and about the
same at home and JM catches about 90%.  So I average 8 uncaught spam per day and
they're spread across multiple accounts and/or folders which means I do this
manual move many times per day.

Not a day goes by that I don't hope to see a comment in this bug saying this is
fixed.  IMHO, this is the one feature left to make the JMC complete (and perhaps
the "disable images, js, etc. when showing junk mail" bug) after which I will
convert all my friends to the pleasures of mozilla 1.4b and junk mail filtering...

Have I mentioned Seth's my hero... :-)
OK, I take your point about multiple mailboxes; mine all come into one so it's
easier. In that case, I'll go along with Alec's comment 6 suggesting pref
controlled.
Should the target be changed to 1.4b, since 1.4a is already out?  Thanks.
adt: nsbeta1+/adt1 

Note to UI/l10n folks: this fix entails a UI change.
Whiteboard: [adt2] → [adt1]
aiming for 1.4 final
Target Milestone: mozilla1.4alpha → mozilla1.4final
for 1.4, I'll probably just to part of
http://www.mozilla.org/mailnews/specs/spam/images/Spam1d.gif, not the whole change.
For the help docs, I can absorb this change before my deadline.
For the UI change: r=bobj.
Added rcloseirl to the cc.  yxia was already on the cc.
Attached image screen shot (obsolete) —
Attachment #123142 - Attachment is obsolete: true
Attached patch patch (obsolete) — Splinter Review
still a work in progress, but the basics work

some todo items:

1) marking as from search (advanced and QS)? (delete / move from search)
2) test various imap delete models
3) UI (and back end), worry about aol and netscape
4) local folders issue (use default server settings?)
5) worry if delete or move is disabled?
6) handle batch 
7) what if in trash or in junk folder already?
8) selecting the next message
9) test undo
10) fix if toggle using thread pane, no selection
Attached patch patch (obsolete) — Splinter Review
1) marking as from search (advanced and QS)? (delete / move from search)

works.

5a) worry if delete or move is disabled

see GetCanDeleteMessages()

6) handle batch mark

works.

7) what if in trash or in junk folder already?

works

if in trash, and we say delete, we don't delete
if in junk, and we say move, we don't move

8) selecting the next message

fixed.

9) test undo

works.

10) fix if toggle using thread pane, no selection

if not toggled thing not selected, select, then run command

todo list for tomorrow:

2) test various imap delete models
3) UI (and back end), worry about aol and netscape
4) local folders issue (use default server settings?)
5b) worry if move is disabled?
Attachment #123234 - Attachment is obsolete: true
Will comment #2 (x sec delay before delete) and/or comment #5 (blink x times
before delete) be considered or even implemented in this round?

Where "x" should be some meaningful default. No need for a UI setting here.
> Will comment #2 (x sec delay before delete) and/or comment #5 (blink x times
> before delete) be considered or even implemented in this round?

From running my patch, I don't think it's needed, since you can undo.
an updated todo list:

2) test various imap delete models
3) UI (and back end), worry about aol and netscape
4) local folders issue (use default server settings?)
5b) worry if move is disabled for the src folder
11) test manual move, but move disabled?
RE: "x-sec delay before delete"

> From running my patch, I don't think it's needed, since you can undo.

I (slightly) disagree:
1. The undo feature is undiscoverable, and is uncommon in this scenario.
2. People might mark-as-junk before having fully read the header - oops.
two issues david found during review:

a)

1,2,3,4 selected, and I toggle the icon for row 1
the move / delete will apply (incorrectly) to all rows

b)

if you classified 20 messages, and selected another message before the
classification finished, those 20 wouldn't get moved / deleted

re-working the patch.
Attached patch patch, still need to test. (obsolete) — Splinter Review
Attachment #123236 - Attachment is obsolete: true
Attached image screenshot
QA:  note how if auto move feature is disabled, the UI for manually move is
disabled.
Attachment #123202 - Attachment is obsolete: true
jon wrote:

> IMHO, this is the one feature left to make the JMC complete (and perhaps
> the "disable images, js, etc. when showing junk mail" bug)

that's bug #179568.

> Have I mentioned Seth's my hero... :-)

even if it took me nearly three months to fix this?
fixed landed, r/sr=bienvenu.

I'm going to address the local folders issue next, in a spin off bug, by most
likely making it show in the JMC dialog, assuming that can be made to make sense.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
one thing I see after building with this patch is that the junk mail controls
dialog needs to be bigger (taller).
Comment on attachment 123296 [details] [diff] [review]
patch, fixed JMC issue (for sure this time)

r/sr=bienvenu, a=sspitzer
Attachment #123296 - Flags: superreview+
Attachment #123296 - Flags: review+
Attachment #123296 - Flags: approval1.4+
Comment on attachment 123361 [details] [diff] [review]
fix, for local folders

r/sr=bienvenu, a=sspitzer
Attachment #123361 - Flags: superreview+
Attachment #123361 - Flags: review+
Attachment #123361 - Flags: approval1.4+
there's one issue (so far) that I need to fix.

an assertion, and a painting issue:

###!!! ASSERTION: selected indices for deletion is 0: 'selectionCount', file c:/
trees/trunk/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 5504

you can get that if you use the thread pane junk status icon and the message
isn't selected.

I'll log a new bug.

> one thing I see after building with this patch is that the junk mail controls
> dialog needs to be bigger (taller).

hmm, let me spin this off.  see bug #205876

> ###!!! ASSERTION: selected indices for deletion is 0: 'selectionCount', file c:/
> trees/trunk/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 5504

> you can get that if you use the thread pane junk status icon and the message
> isn't selected.

spun off to bug #205877
Is this fix functioning as designed?

I have set the prefs to move maually marked messages but, when I do manually
mark one, the Inbox and Junk folder counts update immediately and the status bar
displays Moving 1 of 1 messages to Junk, but the message still appears in the
Inbox header pane. I find I need to switch focus from the Mail window and back
again for it to disappear.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030515
parish: I think bug 205877 deals with that problem.
Using trunk build 20030519 on winxp, macosx and linux
verified, note: the spin off bug 205877 is still open and cam make this appear
as it's not working. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.