Should you be able to edit a replicated LDAP entry via a Palm sync?

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
16 years ago
4 years ago

People

(Reporter: nbaca, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

(Reporter)

Description

16 years ago
Trunk build 2003-02-19: WinXP

Overview: Should you be able to edit a card that was originally an LDAP entry
which was replicated? I found a way to do this via Palm Sync.

This is a remote issue but wanted to log it anyways.

Steps to reproduce:
1. Configure for an LDAP directory
2. Replicate the LDAP directory so it downloads a copy to the local hard drive
(I changed the criteria to only download entries with the name Scott)
3. Perform a palm sync and the palm device displays all the records
4. On the palm device, edit one of the records and add a note (i.e. note1)
5. Perform a palm sync
6. While online in the Mozilla address book query for the entry you just edited
7. While offline in the Mozilla address book query for the same entry

Actual Results:
- After step 6, online, it displays the LDAP entry from the network because I
don't see the note (i.e. note1)
- After step 7, offline, it displays the local copy which displays the note that
was added in the palm. 

I cannot edit the card in the Mozilla AB whether I'm offline or online, as
expected. This behavior doesn't appear to cause any problems but maybe the user
could get into a state where their local and LDAP/network entries won't match.

Then I tried to replicate again, thinking that the replication would over write
the local copy so the "note1" would not appear but this was not the case. It
didn't appear to make any changes to the local entry because I can still see
"note1" while offline.

Expected Results: The current behavior doesn't cause any problems but the user
could get into a state where the local and LDAP/network entry could be out of
sync. Maybe for replicated entries only a one way sync should be possible (sync
from MozAB to the Palm device). If they try to sync from Palm back to MozAB then
disallow this.
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 2

12 years ago
Mark, what do you think? should update via sync be prevented?  
Assignee: mail → bienvenu
Component: Address Book → MailNews: Palm Sync
Product: Mozilla Application Suite → Core
QA Contact: nbaca → vseerror
(In reply to comment #2)
> Mark, what do you think? should update via sync be prevented?  
> 
Yes, this should be prevented. Whilst I'd like to do it in the ab code as well, you may only be able to do it in the palm sync code due to the way palmsync grabs the database from underneath us.

Comment 4

11 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Mark, what do you think? should update via sync be prevented?  
> > 
> Yes, this should be prevented. Whilst I'd like to do it in the ab code as well,
> you may only be able to do it in the palm sync code due to the way palmsync
> grabs the database from underneath us.

Mark, Might this be prevented with the new AB interface you are working on?

(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
QA Contact: vseerror → palm-sync

Comment 5

10 years ago
invalid since we're dropping palm sync
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

10 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard

Updated

10 years ago
Assignee: bienvenu → nobody
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.