Closed Bug 194316 Opened 19 years ago Closed 19 years ago

MacOS X Mozilla acess to the Profile Manager could be improved

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 194149

People

(Reporter: pbergsagel, Assigned: asa)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030214
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030214

I have a question about the profile manager and the Macho Mozilla version for OS
X. Why is there no simpler means (for many users) than some cryptic terminal
commands. Many users will not know how to launch Mozilla from the command line
to gain access to the profile manager. Please take my comments as an observation
and not a criticism of developers, but is there a reason the profile manager is
only accessible through the terminal?

Reproducible: Always

Steps to Reproduce:
Here is a description of the issue:

Today I launched Mozilla. for a reason unknown to me, Mozilla had lost track of
the directory where my profile was and proply quit. I could not launch Mozilla
beyond a couple of bounces of the icon and an error box. I cannot recall the
contents of the error message. Mozilla at this point was broken and useless.

Actual Results:  
Fortunately I had copied the steps to launch Mozilla from the terminal and
access the profile manager from a newsgroup posting a while ago....

% cd Mozilla.app/Contents/MacOS
% ./mozilla-bin -ProfileManager

Typing this into the terminal immediately launched Mozilla openning the profile
manager revealing the location of my user profile. I could inform Mozilla where
to locate the profile. Neither Mozilla nor my profile was corrupted. Mozilla had
somehow lost track of the directory where my profile was stored.

Expected Results:  
Here is the behaviour I would have expected from Mozilla in this case.

1. If Mozilla fails to locate the user's profile the profile manager would pop
up allowing the user to select a profile to use.

and/or

2. Mozilla would provide a methos of accessing the profile manager (apart from
launching Mozilla from the terminal).

Prior to the Macho Mozilla the CFM version included a file titled "Mozilla
Profile Manager" which when doubled clicked would launch the profile manager.
Macho Mozilla could include this functionality.

I suspect the the next release of Netscape for OS X with be based on Macho and
not CFM and will be seriously "broken" for users if they cannot access the
profile manager without launching the app from the terminal.
See bug 194149, just checked in, which lets you launch the profile manager by
holding down the option key when Mozilla is launched.  This should address your
issue.

*** This bug has been marked as a duplicate of 194149 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You can also get to the profile manager at any time by Tools -> Switch Profile.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.