download (ftp) of nightlies doesn't start

RESOLVED DUPLICATE of bug 177053

Status

()

Core
Networking: FTP
--
major
RESOLVED DUPLICATE of bug 177053
16 years ago
15 years ago

People

(Reporter: Jan Vlug, Assigned: dougt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030220
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030220

ftp download of windows nightly does not start on www.mozilla.org

Reproducible: Always

Steps to Reproduce:
1.Go to www.mozilla.org
2.click on the 'Windows' link under 'Nighlty Builds' (right bottom of the page)
3.the status bar shows: Beginning FTP transaction
4.the status bas shows: Connecting to ftp.mozilla.org...

Actual Results:  
Download does not start (the pointer is changed to an arrow and an hourglass).

Expected Results:  
Mozilla should start the download.

When I go to the 'etc.' link and then click on a nightly build the download
starts as expected.

Comment 1

16 years ago
-> Confirming. Happened to me as well : throbber spins a bit and then stops.
Unlike bug 195386 no crash here. 

The SAVE AS dialag doesn't appear. Right-click - Save Target brings up a dialog
but sometimes it takes up to a minute.

Currently Using Moz 2003031508 on XP Pro SP1 but saw this happen in yesterday's
build as welll
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
uninstall mozilla, manually clear out the mozilla folder under program files and
reinstall. That should solve the problem. 

I'm sure there's a dupe out there somewhere (fastload?)..until then INVALID
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
*** Bug 197989 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Jan: any update on how this is working?

Comment 5

16 years ago
Perhaps this is bug 198318?

In that bug, d/l manager also fails to trigger when Moz is installed into a
clean directory.


(Reporter)

Comment 6

16 years ago
I did a clean new install. Currently using:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030317

Still the same problem. Note the differences in the links:

On the Mozilla home page:
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe

On the Index of /pub/mozilla/nightly/latest page:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe

Comment 7

16 years ago
REOPEN:
please put the URL that is not working in the URL field.

If you did the uninstall, then the next troubleshooting is to create a new
profile and try to download w/ it.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 8

16 years ago
I have the problem on a laptop. I experience the problem at my office.
Yesterday I tried at home. There I have no problems.
Maybe it has something todo with the firewall configuration.
However, I tried the download on my office with an ftp program, that was not
configured to use passive mode. This worked out fine.

Next week, I will try with a new profile. I will also try with MS IE, to be sure
that it is not an firewall issue.
(Reporter)

Comment 9

16 years ago
MS IE does not download either.
With a new profile the download does not start either.
So, it is probably a firewall configuration problem.
Marking INVALID.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Comment 10

16 years ago
v. 
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

15 years ago
I tried again with Mozilla. After approximately 9 minutes this showed up in a
pop-up window:
425: Can't open data connection.

Comment 12

15 years ago
Sorry, really behind on bugmail.

This is a valid bug, we don't report an error when we fail to open the DATA
connection. The most likely cause is the firewall just drops the packets, which
results in a connection establishment timeout.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---

Comment 13

15 years ago
I didn't realize that IE didn't report errors correctly in this situation either.

If you really wanted to know for sure, you could probably reproduce the steps by
hand by using two telnet sessions. The second would fail if you read the PASV
output correctly :)

*** This bug has been marked as a duplicate of 177053 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 14

15 years ago
Info from the reporter:

220 ftpmoz.newaol.com FTP server (SunOS 5.8) ready.
USER anonymous
331 Guest login ok, send your complete e-mail address as password.
PASS wr26244@wolmail.nl
230 Guest login ok, access restrictions apply.
PASV
227 Entering Passive Mode (207,200,85,49,206,253)
PWD
257 "/" is current directory.
LIST

after approximately 9 minutes:

425 Can't open data connection.

Next I tried again with Mozilla. Again after approximately 9 minutes this showed
up in a pop-up window:
425: Can't open data connection.

I'm going to see if we can get more info on the DATA connection failure. At this
point, that 425 error happened because the TELNET client doesn't make the data
connection automatically.
(Reporter)

Comment 15

15 years ago
I installed linux Red Hat 9 on my laptop:
I tried again with:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

After approximately 30 seconds I get an popup window with this text:
/tmp/....exe could not be saved, because the source file could not be read. Try
again later, or contact the server administrator.

Thus here I do get an error message.

I also tried the download with a command line ftp client with the -d option.
This are te results:

--- start of copy of ftp client
ftp> open ftp.mozilla.org
Connected to ftp.mozilla.org (64.12.168.243).
220 ftpmoz.newaol.com FTP server (SunOS 5.8) ready.
Name (ftp.mozilla.org:jan): anonymous
---> USER anonymous
331 Guest login ok, send your complete e-mail address as password.
Password:
---> PASS XXXX
230 Guest login ok, access restrictions apply.
---> SYST
215 UNIX Type: L8 Version: SUNOS
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (64,12,168,243,130,180)

------
Here I pressed CTRL-C
------
 
receive aborted
waiting for remote to finish abort
--- end of copy of ftp client

So here you can see an error in the output...
(Reporter)

Comment 16

15 years ago
I tried again (with the ftp client with -d option from linux) without pressing
CTRL-C. It takes approximately 3 minutes to get the 'Connection timed out' message.
This are te results:

Name (ftp.mozilla.org:jan): anonymous
---> USER anonymous
331 Guest login ok, send your complete e-mail address as password.
Password:
---> PASS XXXX
230 Guest login ok, access restrictions apply.
---> SYST
215 UNIX Type: L8 Version: SUNOS
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (207,200,85,49,169,27)
ftp: connect: Connection timed out
You need to log in before you can comment on or make changes to this bug.