Browser crashes with no warning, blink and its gone.

RESOLVED DUPLICATE of bug 185357

Status

()

Core
Printing: Output
--
major
RESOLVED DUPLICATE of bug 185357
15 years ago
15 years ago

People

(Reporter: Brian C. Lane, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Nothing to expand on. Try printing this page and it crashes.


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.dol.wa.gov/ds/maps/poulsbo.htm
2. Select Ftile->Print 
3. Select ok

Actual Results:  
Browser crashes and all windows (including mail) close.

Expected Results:  
Print the damn page

Comment 1

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030220
WFM

Comment 2

15 years ago
Trying to reproduce the bug resulted in crashing in Print Preview. 
Talkback ID: TB17386581X
Mozilla build 2003022008 on Windows 2000.
nsIFrame::GetNextSibling(nsIFrame * * 0x0012957c) line 707 + 6 bytes
nsLineBox::LastChild() line 254
nsBlockFrame::PushLines(nsBlockReflowState & {...}, nsLineList_iterator {...}) 
line 4588 + 17 bytes
nsBlockFrame::PushTruncatedPlaceholderLine(nsBlockReflowState & {...}, 
nsLineList_iterator {...}, nsIFrame * 0x00000000, int & 1) line 3647
nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState & {...}, nsLineLayout & 
{...}, nsLineList_iterator {...}, int * 0x00129d30, unsigned char * 0x00129b13, 
int 0, int 0) line 3749
nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState & {...}, 
nsLineList_iterator {...}, int * 0x00129d30, unsigned char * 0x00129b13, int 0, 
int 0) line 3628 + 46 bytes
nsBlockFrame::ReflowInlineFrames(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x00129d30, int 0, int 0) line 3572 + 36 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x00129d30, int 0) line 2664 + 33 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2310 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x056a866c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 943 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x056a866c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 
30, int 30, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x056a85cc, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 947
nsContainerFrame::ReflowChild(nsIFrame * 0x056a85cc, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 
15, int 0, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
nsTableRowFrame::ReflowChildren(nsTableRowFrame * const 0x056a8470, 
nsIPresContext * 0x056be120, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, nsTableFrame & {...}, unsigned int & 0, int 0) line 
1052 + 45 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x056a8470, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1465 + 37 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x056a8470, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 3, unsigned int & 0) line 959 + 31 bytes
nsTableRowGroupFrame::SplitRowGroup(nsIPresContext * 0x056be120, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, nsTableFrame * 
0x056a82d4, unsigned int & 0) line 1131 + 43 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x056a83a4, 
nsIPresContext * 0x056be120, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1370
nsContainerFrame::ReflowChild(nsIFrame * 0x056a83a4, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 15, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
nsTableFrame::ReflowChildren(nsTableFrame * const 0x056a82d4, nsIPresContext * 
0x056be120, nsTableReflowState & {...}, int 1, int 0, unsigned int & 0, nsIFrame 
* & 0x00000000, int * 0x00000000) line 3309 + 50 bytes
nsTableFrame::ReflowTable(nsIPresContext * 0x056be120, nsHTMLReflowMetrics & 
{...}, const nsHTMLReflowState & {...}, int 5265, nsReflowReason 
eReflowReason_Resize, nsIFrame * & 0x00000000, int & 0, int & 1, unsigned int & 
0) line 2213
nsTableFrame::Reflow(nsTableFrame * const 0x056a82d4, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 2072
nsContainerFrame::ReflowChild(nsIFrame * 0x056a82d4, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 3, unsigned int & 0) line 959 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x056a81b8, 
nsIPresContext * 0x056be120, nsIFrame * 0x056a82d4, const nsHTMLReflowState & 
{...}, nsHTMLReflowMetrics & {...}, int 9888, nsSize & {...}, nsMargin & {...}, 
nsMargin & {...}, nsMargin & {...}, nsReflowReason eReflowReason_Initial, 
unsigned int & 0) line 1342 + 47 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x056a81b8, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1988 + 74 bytes
nsBlockReflowContext::ReflowBlock(const nsRect & {...}, int 0, 
nsCollapsingMargin & {...}, int 1, nsMargin & {...}, nsHTMLReflowState & {...}, 
unsigned int & 0) line 546 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012ba3c) line 3330 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012ba3c, int 0) line 2528 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2310 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x056a8094, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 943 + 15 bytes
nsBlockReflowContext::ReflowBlock(const nsRect & {...}, int 1, 
nsCollapsingMargin & {...}, int 0, nsMargin & {...}, nsHTMLReflowState & {...}, 
unsigned int & 0) line 546 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012c564) line 3330 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012c564, int 0) line 2528 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2310 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x05647008, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 943 + 15 bytes
nsBlockReflowContext::ReflowBlock(const nsRect & {...}, int 0, 
nsCollapsingMargin & {...}, int 1, nsMargin & {...}, nsHTMLReflowState & {...}, 
unsigned int & 0) line 546 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012d08c) line 3330 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012d08c, int 0) line 2528 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2310 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x0564714c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 943 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0564714c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
nsPageContentFrame::Reflow(nsPageContentFrame * const 0x056470f8, nsIPresContext 
* 0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 102
nsContainerFrame::ReflowChild(nsIFrame * 0x056470f8, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 
1170, int 1170, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
nsPageFrame::Reflow(nsPageFrame * const 0x0564708c, nsIPresContext * 0x056be120, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 223
nsContainerFrame::ReflowChild(nsIFrame * 0x0564708c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 
360, int 17556, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
nsSimplePageSequenceFrame::Reflow(nsSimplePageSequenceFrame * const 0x056e0834, 
nsIPresContext * 0x056be120, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 447
nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState & {...}, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0, int 0, int 0, int 11568, int 15876, int 1) line 902
nsBoxToBlockAdaptor::DoLayout(nsBoxToBlockAdaptor * const 0x0583a0b4, 
nsBoxLayoutState & {...}) line 646 + 46 bytes
nsBox::Layout(nsBox * const 0x0583a0b4, nsBoxLayoutState & {...}) line 1074
nsScrollBoxFrame::DoLayout(nsScrollBoxFrame * const 0x056e0d80, nsBoxLayoutState 
& {...}) line 361
nsBox::Layout(nsBox * const 0x056e0d80, nsBoxLayoutState & {...}) line 1074
nsContainerBox::LayoutChildAt(nsBoxLayoutState & {...}, nsIBox * 0x056e0d80, 
const nsRect & {...}) line 643 + 16 bytes
nsGfxScrollFrameInner::LayoutBox(nsBoxLayoutState & {...}, nsIBox * 0x056e0d80, 
const nsRect & {...}) line 1153 + 17 bytes
nsGfxScrollFrameInner::Layout(nsBoxLayoutState & {...}) line 1308
nsGfxScrollFrame::DoLayout(nsGfxScrollFrame * const 0x056e0c64, nsBoxLayoutState 
& {...}) line 1161 + 15 bytes
nsBox::Layout(nsBox * const 0x056e0c64, nsBoxLayoutState & {...}) line 1074
nsBoxFrame::Reflow(nsBoxFrame * const 0x056e0c2c, nsIPresContext * 0x056be120, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 902
nsGfxScrollFrame::Reflow(nsGfxScrollFrame * const 0x056e0c2c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 845 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x056e0c2c, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 959 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x056e0728, nsIPresContext * 
0x056be120, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 298 + 43 bytes
PresShell::InitialReflow(PresShell * const 0x0481eb48, int 11568, int 15876) 
line 2797
nsPrintEngine::ReflowPrintObject(nsPrintObject * 0x055aa308, int 1) line 2824 + 
43 bytes
nsPrintEngine::ReflowDocList(nsPrintObject * 0x055aa308, int 0, int 1) line 2573 
+ 16 bytes
nsPrintEngine::SetupToPrintContent(nsIDeviceContext * 0x055dd418, 
nsIDOMWindowInternal * 0x00000000) line 2394 + 32 bytes
nsPrintEngine::DocumentReadyForPrinting() line 2221 + 38 bytes
nsPrintEngine::FinishPrintPreview() line 4552 + 8 bytes
nsPrintEngine::PrintPreview(nsPrintEngine * const 0x0572ee30, nsIPrintSettings * 
0x04a2fe68, nsIDOMWindow * 0x00000000, nsIWebProgressListener * 0x058583b4) line 
1272 + 8 bytes
DocumentViewerImpl::PrintPreview(DocumentViewerImpl * const 0x054adbe0, 
nsIPrintSettings * 0x04a2fe68, nsIDOMWindow * 0x00000000, nsIWebProgressListener 
* 0x058583b4) line 3141 + 30 bytes
XPTC_InvokeByIndex(nsISupports * 0x054adbe0, unsigned int 14, unsigned int 3, 
nsXPTCVariant * 0x0012ed4c) line 102
XPCWrappedNative::CallMethod(XPCCallContext & {...}, XPCWrappedNative::CallMode 
CALL_METHOD) line 2023 + 42 bytes
XPC_WN_CallMethod(JSContext * 0x00e14938, JSObject * 0x00ff4f40, unsigned int 3, 
long * 0x053d5068, long * 0x0012effc) line 1292 + 14 bytes
js_Invoke(JSContext * 0x00e14938, unsigned int 3, unsigned int 0) line 843 + 23 
bytes
js_Interpret(JSContext * 0x00e14938, long * 0x0012f990) line 2811 + 15 bytes
js_Invoke(JSContext * 0x00e14938, unsigned int 1, unsigned int 2) line 860 + 13 
bytes
js_InternalInvoke(JSContext * 0x00e14938, JSObject * 0x00e16368, long 61801040, 
unsigned int 0, unsigned int 1, long * 0x0557e8d8, long * 0x0012fac0) line 935 + 
20 bytes
JS_CallFunctionValue(JSContext * 0x00e14938, JSObject * 0x00e16368, long 
61801040, unsigned int 1, long * 0x0557e8d8, long * 0x0012fac0) line 3431 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x039fca18, void * 0x00e16368, 
void * 0x03af0250, unsigned int 1, void * 0x0557e8d8, int * 0x0012fb4c, int 0) 
line 1040 + 33 bytes
GlobalWindowImpl::RunTimeout(nsTimeoutImpl * 0x044b9eb0) line 4735 + 84 bytes
GlobalWindowImpl::TimerCallback(nsITimer * 0x039c9058, void * 0x044b9eb0) line 
5095
nsTimerImpl::Fire() line 382 + 17 bytes
nsTimerManager::FireNextIdleTimer(nsTimerManager * const 0x039289a0) line 616
nsAppShell::Run(nsAppShell * const 0x03840550) line 176
nsAppShellService::Run(nsAppShellService * const 0x03840490) line 480
main1(int 2, char * * 0x00262580, nsISupports * 0x03826df0) line 1273 + 32 bytes
main(int 2, char * * 0x00262580) line 1636 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e8ca90()

*** This bug has been marked as a duplicate of 185357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.