Moving mouse very fast occasionally leaves wrong pointer selected

RESOLVED WORKSFORME

Status

()

Core
Event Handling
P3
minor
RESOLVED WORKSFORME
19 years ago
9 years ago

People

(Reporter: Adam Masri, Unassigned)

Tracking

({helpwanted})

Trunk
Future
PowerPC
Mac OS X
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Build ID: 1999111612
OS: MacOS 9 (please add)
Platform: Macintosh PowerBook G3/300, 128Mb RAM, VM off.

Try the following: go to the Bugzilla home page. Move the mouse over the
mozilla.org banner at the top of the page, and stop moving the mouse completely
for a moment so that your pointer changes from an arrow to the hand. Now, move
the mouse VERY fast towards the menu bar. You may have to do this several times
to see it, but occasionally Moz will not change the pointer back to the arrow
shape; the pointer will be left as the hand, or may even change to an i-beam
(since you passed over the site bar as you left the Moz window). This does not
appear to happen if you move the mouse slowly over different areas of Moz.

Updated

19 years ago
Assignee: shuang → leger
Component: UE/UI → Browser-General

Comment 1

19 years ago
not sure what the problem is: feedback or speed or both ( or something else).
reassign it to browser component for now.

Comment 2

19 years ago
The bug here is surely that the mouse pointer gets stuck in the wrong mode,
missing a notification.

I've seen this many times in other apps in Windows (all versions), particularly
when a very fast graphics accelerator is installed and the app's UI is very
complex.

Could not replicate on NT with 1999-11-19-09-M12 no matter how much I loaded
down the system (100% CPU, heavy swapping) although when the system was
most loaded down the pointer did not change to the i-beam as it passed over
the location bar when moving the mouse quickly.

Despite that, it *is* possible that this is a cross-platform problem,
rather than Mac-only: one data point can't disconfirm that hypothesis.

Tested with: 1999-11-19-09-M12 nightly binary on Windows NT 4.0sp3,
64 MB memory, commit charge double that, Matrox Millenium video accelerator
(original version).

Updated

19 years ago
Assignee: leger → joki
Component: Browser-General → Event Handling
QA Contact: claudius → janc

Comment 3

19 years ago
Updating QA Contact/Component
(Reporter)

Comment 4

19 years ago
Build ID: 2000012601 (M13)
OS: MacOS 9

Please note that this bug still occurs under M13. I can get this to occur simply
by moving the mouse into the location bar, clicking (so I get the i-beam
pointer), then moving very fast into the menu bar. Often, the i-beam is still
left as the pointer, even though it should have changed into the arrow pointer.
I am able to get it to fail with 3/3/2000 build of mozilla on the Mac. I had to 
place the pointer over the url bar then "flick" the mouse to get it to move 
quickly enough to the see that the cursor remained an I-beam. We must not be 
getting the mouse exit when it is moving quickly. On WIN32 I can not get it to 
leave the I beam. My guess is that this particular problem is Mac only.

Re-assigning to dcone to verify that the exit event is being generated on the 
Mac.
Assignee: joki → dcone

Comment 6

19 years ago
*** Bug 25745 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
I think I am experiencing a similar problem with fast mouse movement (Win98
build 2000030215).  I have a test page at
http://www.vortxweb.net/ccs-pg/holidays/mz_aprilfool.shtml which has cursor
trails.  If you move the cursor *very* slowly, you get the desired effect.  Move
the cursor any faster and it's choppy and sluggish.  View the page in NS4.x or
IE5 and the trails flow smoothly at any speed.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Updated

18 years ago
Target Milestone: M15 → M16

Updated

18 years ago
Target Milestone: M16 → M17

Updated

18 years ago
Target Milestone: M17 → M18

Comment 8

18 years ago
Don't think cursor trails are related. Updating OS to All. Mozilla M16 
2000042010, Mac OS 9.0.4.
OS: Mac System 8.6 → All

Comment 9

18 years ago
*** Bug 36421 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M18 → Future

Comment 10

18 years ago
This bug has been marked future because we have determined that it is not 
critical for netscape 6.0.  If you feel this is an error, or if it blocks your 
work in some way -- please attach your concern to the bug for reconsideration.

Comment 11

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 12

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca

Comment 13

18 years ago
This has become extremely ridiculous in recent times. You don't even have to
move the cursor fast to have the pointer stick. And it's a biotch to get it back
to the correct pointer. This has become more than a trivial problem. Netscape
6.00 and Mozilla 2000111708, Mac OS 9.0.4.
Assignee: dcone → joki
Severity: trivial → normal
Status: ASSIGNED → NEW
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 15

18 years ago
joki, care to comment if the future is any time soon?  This definitely seems like 
it'd fall into the polish category which is a hot topic for the next release.
nominating for dogfood (from sdagley's list of bugs that are good candidates for 
our next release) 
Keywords: nsdogfood
Keywords: nsCatFood
Keywords: nsdogfood
taking this over, i think i might have some ideas
Target Milestone: Future → mozilla0.9.1

Comment 18

17 years ago
The last comment here is from pink saying he was taking this over.  Assigning 
over to him to see if that's true.  I believe the remaining problem is Mac only 
anyway so we'll need a Mac guy on this anyway.
Assignee: joki → pinkerton

Comment 19

17 years ago
Sorry, but we can't afford this level of polish right now.  ->0.9.3/helpwanted
Keywords: helpwanted
Target Milestone: mozilla0.9.1 → mozilla0.9.3
Target Milestone: mozilla0.9.3 → Future

Comment 20

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Comment 21

16 years ago
Still able to reproduce this using FizzillaCFM/2002080508.

Comment 22

16 years ago
Would fixing bug 106692 help this at all?

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 23

15 years ago
Changing OS to the only Mac OS version that matters any more.
OS: All → MacOS X

Comment 24

15 years ago
Tested recently with latest Firebird 0.6 and Moz 1.3 milestones in OS X 10.1.5
and the bug still exists.

Comment 25

9 years ago
Jay, others, do you still see this?
Assignee: mikepinkerton → nobody
Severity: normal → minor
QA Contact: trix → events
Okay, I want the last 5 minutes of my life back. :)

I attempted to get this to reproduce for a few minutes, probably tried over a 100 times. One time I did have the hand for a very short timeframe (maybe 200ms), but it switched back to pointer.

This is on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

Running on OSX 10.5.6.

WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.