microsoft.com - MS Office page reports mozilla as an unsupported browser

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Other
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Eugene, Unassigned)

Tracking

({top100, top500})

Details

(URL)

(Reporter)

Description

16 years ago
The brower is reported as unsupported in a header, telling me to use IE 5.01 or
above, or to look at list of supported browsers. Clicking on list of supported
browsers yields a "service unavilable" page.
Saving html with IE and displaying it in Mozilla yields correct layout - looks
almost the same!
Currently this site displays: "To view this page properly, upgrade to Microsoft
Internet Explorer 5.01 or later or Netscape Navigator 6.0 or later".

After changing useragent string to "Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:0.9.4) Gecko/20011022 Netscape6/6.2" the page opened.

So, they have a Gecko-capable version of their website, but allow only one
Gecko-browser... What for?

Comment 2

15 years ago
-> evang500
Keywords: evang500

Comment 3

15 years ago
-> other
Assignee: momoi → other
Component: The Americas → Other
QA Contact: jonrubin → other

Comment 4

15 years ago
*** Bug 223869 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Updating URL.  The Office beta URL
http://officebeta.microsoft.com/home/default.aspx just routes to the current
Office URL now.  And the problem has persisted.
Summary: OfficeBeta reports mozilla as an unsupported browser → MS Office page reports mozilla as an unsupported browser

Comment 6

14 years ago
*** Bug 245590 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
(In reply to comment #1)
> Currently this site displays: "To view this page properly, upgrade to Microsoft
> Internet Explorer 5.01 or later or Netscape Navigator 6.0 or later".
> 
> After changing useragent string to "Mozilla/5.0 (X11; U; Linux i686; en-US;
> rv:0.9.4) Gecko/20011022 Netscape6/6.2" the page opened.
> 
> So, they have a Gecko-capable version of their website, but allow only one
> Gecko-browser... What for?

How do you change the useragent in Mozilla?

Comment 9

14 years ago
*** Bug 266125 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: MS Office page reports mozilla as an unsupported browser → microsoft.com - MS Office page reports mozilla as an unsupported browser

Comment 11

14 years ago
I have today left an comment to the webmaster on the German version of this site
(you are automatically redirected if you prefer DE to
http://office.microsoft.com/de-de/default.aspx) about their failure in the help
about browser requirements. I referenced this bug. With faked UA as NS 7.2 the
site works well.

Updated

14 years ago
Keywords: top500

Updated

14 years ago
Keywords: top100
All links mentioned here now WFM.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050523
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051029 Firefox/1.6a1

Resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 13

13 years ago
Same for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051028 SeaMonkey/1.1a.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.