"Document contains no data" message frequently appears for no apparent reason.

VERIFIED DUPLICATE of bug 189965

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 189965
16 years ago
16 years ago

People

(Reporter: Andy Fielding, Assigned: asa)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

One concrete example is whenever I log on to Yahoo Mail. Otherwise, it seems
like it happens randomly. This just started happening when I upgraded to 1.3b;
it never happened with 1.2.1.

Reproducible: Always

Steps to Reproduce:
1. Log on to Yahoo Mail. (You must have an account there.)
2. The message appears.
3. You have a coffee and write crazy email. (Well, that's optional.)

Actual Results:  
The message appeared. (You don't mean the coffee/email thing, do you?)

Expected Results:  
Not shown the message, I guess.

Maybe an unseen part of the page is loading that Mozilla doesn't understand...?
(Reporter)

Comment 1

16 years ago
[Later] Ah---I think I know why this may be happening: Ad-blocking. When I was
using Mozilla 1.2.1, I used the right-click/image-blocking feature to block ads
from Yahoo. I also use a Hosts-type textfile that points to Localhost
(127.0.0.1) whenever ads from known ad-servers are detected. I suspect that
Mozilla 1.31b doesn't know how to handle one or both of these.

Comment 2

16 years ago
wfm Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203
once in a while i would get that message, but it's been a long while,
actually come to think of it, i may have an idea about this. It happens to me
when i open a new tab with middle click and close this new tab quickly without
waiting a second or so before opening another tab from the original page. So
basicaly you should click on an empty space in the original page and then on a
link.  I also noticed that this happens when switching between workspaces in
gnome. It might partially be x11 because when you switch workspaces the mouse
acts(for an extremely short time) as if you havent raised the window but at the
same time that workspace contains mozilla so when you click on a link the mouse
executes a blank function without actually going to the link. Thats my two cents.

*** This bug has been marked as a duplicate of 189965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Adam: That's interesting---but, as it turned out, I had a different problem.

Matti: No, this bug is not a duplicate. 189965 is related to Yahoo Mail, but
that's the only similarity.

I found out what caused this. As I mentioned, I suspected it was related to
ad-blocking. 

I use a Cookperm.txt file (in my Mozilla "Profile" folder) that contains a list
of DNS numbers of known ad-servers. When Mozilla gets a header from one of them,
it consults the file, which directs it to my local machine (127.0.0.0) instead
of the ad server. Naturally, the ad-file isn't found my own machine, and the ad
isn't displayed. (This is similar to the "Hosts" file for IE users.) See
http://www.deftone.com/blogzilla/archives/ad_blocking.html for more details.

It worked fine with Mozilla 1.2.1, but some change to 1.3b prevented it from
working correctly. I found this fix on mozillaZine.com:

(1) Exit Mozilla.
(2) Find Prefs.jsn---which will reside in a Mozilla settings folder on your
system (but not necessarily in the main Mozilla folder)---and open it in a text
editor.
(3) Add this line to the file:
    user_pref("browser.xul.error_pages.enabled", true);
(4) Save the file and rerun Mozilla.

I don't know if this is a "bug"---maybe just customization advice? I've marked
it "reopen" anyway; you guys can decide.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

16 years ago
P.S.: Speaking of mozillazine.com, that's one of the pages that raises the error
message (if you're using Cookperm.txt). So it's a good test-page. :?)
That's a dupe of bug 189965.

Please read the bug before you reopn this one.
You redirect the ads to localhost and what do you think Mozilla gets if it tries
to access you localhost for the ad ?
A connection error and what's the summary of that bug ?

*** This bug has been marked as a duplicate of 189965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
VERIFIED dupe.
Status: RESOLVED → VERIFIED
Component: Browser-General → Networking
QA Contact: asa → benc
You need to log in before you can comment on or make changes to this bug.