Closed Bug 194575 Opened 17 years ago Closed 11 years ago

should use Carbon umbrella frameworks

Categories

(SeaMonkey :: Build Config, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 482277

People

(Reporter: sbwoodside, Assigned: ccarlen)

References

()

Details

There are a lot of includes that are delimited by #ifdef XP_MACOSX that use the
old non-umbrella carbon headers (presumably through the FlatCarbon stubs). On
Mac OS X, Mozilla should use the Carbon/Carbon.h umbrella header.
Is there anything that Apple doesn't have a guideline for? (besides not bumping
system library versions when applying fixes)
Assignee: seawood → ccarlen
Now that we only build under OSX, we could just move to using framework style
#includes and no longer use the FlatCarbon method. But, this sounds like a huge
amount of tedious work and I'm not sure what the gain would be. One interesting
thing the guideline says: "Once you are only compiling code for Mac OS X, you
should start using the native syntax for including umbrella frameworks. (As a
side effect of doing this, build time will decrease.)" How much it would
decrease would be good to know. If significant, that'd be nice.
Product: Browser → Seamonkey
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482277
You need to log in before you can comment on or make changes to this bug.