Different syntax for local files in 1.2.1 and 1.3b

RESOLVED WONTFIX

Status

SeaMonkey
General
--
minor
RESOLVED WONTFIX
15 years ago
13 years ago

People

(Reporter: Gulliver, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030210

1.3b uses a syntax for local files in the form
file:///Volumes/harddisk/path_to_file while 1.2.1 uses
file:///harddisk/path_to_file. This is not really a problem as long as you do
not need to use 1.2.1 in OS 9 and use the same user profile for both versions.
But when you do and you have a local file as startup-page this is very annoying.

Reproducible: Always

Steps to Reproduce:
1.Define a local file as startup page
2.Launch 1.2.1 or 1.3b and select this as startup page in preferences.
3.Save and quit
4.Startup in the other version (regardless whether in OSX or OS9)

Actual Results:  
Default startup page (Welcome to Mozilla.org) is displayed.


There is also an incompatibility in the preferences between 1.2.1 and 1.3b
regarding the settings for tabbed browsing. Sometimes (not always) these setting
are set back to default when changing between versions.
install the 1.2.1 macho build ?
I use the easy way : this is a error in the classic build. This can't be fixed
since 1.2.1 is the last classic build.
Mozilla.org provides now only macho builds 

-> wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.