Mozilla won't load on Win95 OSR1 w/o IE 3.0

VERIFIED FIXED in M14

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: dbialac, Assigned: Jon Granrose)

Tracking

({relnote})

Trunk
x86
Windows 95
relnote

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
Mozilla seems to use a DLL who use Win95 OSR1 or earlier without IE 3.0 or later
installed.

Replication:
Install Win95 (original edition) or OSR1.
Mozilla will come up with a dialog box proclaiming that the required DLL is
unavailable (unfortunately, I didn't write down the name of the DLL :<)

Updated

19 years ago
Assignee: leger → granrose
Component: Browser-General → Build Config

Comment 1

19 years ago
build config?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
I don't think we have a win95 system in build, let alone an original or OSR1
system.  We'll need to track one down and find out what file we're missing.
(Reporter)

Comment 3

19 years ago
I haven't had access to the computer I was using for a little while.  I should be able to try this on a similarly configured computer in a few days and give you the name of the dll.
(Assignee)

Updated

19 years ago
Target Milestone: M14
(Assignee)

Comment 4

19 years ago
what happens when you run win95 with service pack 1 installed (shows up as
4.00.95a in Control Panel|System or something like that as it adds an a to the
end of the plain vanilla version)?  Having just spent my holidays installing
many many patches to relatives' win95 and win98 systems, I'm 95% sure whatever
DLL is missing we can find a patch on Microsoft's web site that includes it and
point people to it via release notes.
(Assignee)

Comment 5

19 years ago
not much to do with this without the name of the missing dll and no win95 OSR1 
system to test this on.

cc'ing leaf and ssu.  you guys heard anything similar to this?
Summary: Mozilla won't load on Windows w/o IE 3.0 → Mozilla won't load on Win95 OSR1 w/o IE 3.0

Comment 6

19 years ago
I haven't seen this problem before.  We need to find a Win95 OSR1 to find out 
what dlls it will complain about.  Does QA have any such a system?
(Assignee)

Comment 7

19 years ago
raising visibility of this bug.  no one has a win95 osr1 system to confirm if 
this is a valid bug or not.
Keywords: beta1

Comment 8

19 years ago
Putting on the PDT- radar for beta1.  Won't hold for beta.  We can release note.
Keywords: relnote
Whiteboard: [PDT-]

Comment 9

19 years ago
dbialac@cse.unl.edu, have you been able to check back with an old Win95 
system to find out the name of the required-but-missing DLL?
(Reporter)

Comment 10

19 years ago
I tried the Installer.exe distribution of M13, and it works without IE.  Looks
like you've included the dlls.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 11

19 years ago
Adding verifyme keyword.
Keywords: verifyme

Comment 12

19 years ago
verified, works for orignal reporter and other OSR1 people

Comment 13

19 years ago
verified, works for orignal reporter and other OSR1 people
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.