[quirks]proportional size doesn't work properly when used in a table without size markup

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: willem vermin, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

421 bytes, text/html
Details
448 bytes, text/html
Details
430 bytes, text/html
Details
457 bytes, text/html
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1

The <select> box in a table gets width and height zero when used in a table
that has no width and height set. 
demonstration: http://home.sara.nl/~willem/test.html (table with no width and
height)
compare this with: http://home.sara.nl/~willem/test1.html (table with width and
heigth)


Reproducible: Always

Steps to Reproduce:
1.look at url http://home.sara.nl/~willem/test.html  
2.look at url http://home.sara.nl/~willem/test1.html
3.

Actual Results:  
After step 1: wrong formatted <select>
After step 2: good formatted <select>

Expected Results:  
The result of step 2

Netscape 4.77 doesn't display this behaviour.
->form controls
Assignee: dbaron → form
Component: Style System → Layout: Form Controls
QA Contact: ian → desale
This is working fine on trunk; no idea what fixed this in the 10 months since
1.0, but....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
Ok, but when a <p> is added, also in Mozilla 1.3 the problem
reappears: see http://home.sara.nl/~willem/test2.html

The problem persists then , even if the table is defined
with width and height: http://home.sara.nl/~willem/test3.html
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
More of the same table problems... sigh.  (Note that per CSS spec the height
style on that <select> should just be ignored here....)
Assignee: form → table
Component: Layout: Form Controls → Layout: Tables
QA Contact: desale → madhur
Summary: proportional size doesn't work properly when used in a table without size markup → [quirks]proportional size doesn't work properly when used in a table without size markup
Whiteboard: DUPEME

Comment 5

15 years ago
could it be dup of bug 10212 ??

Comment 6

14 years ago
Created attachment 140523 [details]
test.html

Comment 7

14 years ago
Created attachment 140524 [details]
test1.html

Comment 8

14 years ago
Created attachment 140525 [details]
test2.html

Comment 9

14 years ago
Created attachment 140526 [details]
test3.html

Comment 10

14 years ago
works for me in all cases. winxp 2004012808
Didn't this get fixed by the checkin for bug 222730?  The heights are definitely
working "correctly" now, and imo so are the widths....
Ah, excellent.  Resolving, per comment 10 and comment 11 -- fixed by checkin for
bug 222730
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.