Triple-click doesn't select entire entry in URL window

RESOLVED DUPLICATE of bug 257363

Status

()

Core
Selection
RESOLVED DUPLICATE of bug 257363
15 years ago
12 years ago

People

(Reporter: Scott Ripley, Assigned: mjudge)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

If I triple-click in the URL window, it should select the entire entry (so I can
type in a new one) but it only selects a single word.

Thus I have to manually select the entry by dragging the mouse over it.

Reproducible: Always

Steps to Reproduce:
1. Click once
2. Click twice
3. Click a third time, quickly now!

Actual Results:  
It only selects a portion, usually a word, of the URL.

Expected Results:  
As in previous versions, it should select the entire line so I can delete it by
typing. This is especially important when the URL runs "off" the screen so I
can't select the entire thing by dragging my cursor.
->Selection (wfm with todays win2k)
Assignee: asa → mjudge
Component: Browser-General → Selection
QA Contact: asa → pmac
(Reporter)

Comment 2

15 years ago
I've finessed the behaviour some...
When I first make a new window, it will select the entire URL with a
triple-click. But on subsequent tries, it won't.
HOWEVER,
if I try to select the entire URL, then go to another window, then come BACK to
my original window, the entire URL is selected. If I deselect that, then try
triple-clicking again, it goes back to only selecting a single word or section.

Comment 3

15 years ago
WFM. 2003022404 / XP.

Comment 4

15 years ago
WFM on 1.3b/Win98, but apparently the reporter is not the only one seeing this
(see bug 62491 comment 23), so confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
I had the same problem until I set the double-click speed to a lower value in my
mouse preferences, then triple-click works again every time. Note that the
double-click was quite fast but worked all of the time
(Reporter)

Comment 6

15 years ago
I tried Mr. bkuemmer@gmx.net's suggestion and it is true that turning down the
double-click speed does help. I had mine set to highly-caffinated; now it's set
to George W. Bush and the slower speed does help.

Not be persnickety, but this speed did work in the 1.2 build, so something has
changed on Mozilla's side. For now I'll continue to browse at the speed of POTUS.

Comment 7

15 years ago
FWIW I would like to mention there was a discussion of this issue on
slashdot: http://slashdot.org/comments.pl?sid=68828&cid=6293156

I also observe the triple-clicking problem on Windows.  When I set the
mouse speed fast (which I want to do for other Windows apps) I can't
get the triple-click to work.  When I set it slower, it will work, but
only if I triple-click at just the right speed (not too fast and not too
slow).

My suggestion would be to add a new user pref that would revert to the
"double-click selects all" behavior of pre-1.3.  This would be
consistent with the behavior of other location bars in Windows (for
better or worse) and would make everyone happy.  I understand the
"philosophy" behind the triple-click, but in practice I personally
hardly ever find a use for the "word" that double-click selects.
From the latests comments, it appears that this is the same issue as described in bug 257363. Since that bug has a clearer description, duplicating this to that one.

*** This bug has been marked as a duplicate of 257363 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.