mozilla hangs after preview or printing using xprint

RESOLVED DUPLICATE of bug 193081

Status

Core Graveyard
Printing: Xprint
--
critical
RESOLVED DUPLICATE of bug 193081
15 years ago
10 years ago

People

(Reporter: Linus Ericson, Assigned: Masaki Katakai)

Tracking

({hang, stackwanted})

Trunk
x86
Linux
hang, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Need stacktrace from talkback TB17480960Y)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

I just installed xprint 007, an now Mozilla hangs after I print something or
close the print preview.

It does not matter if I print to my printer (via SMB) or print to a file, the
progress bar never disappears. The Mozilla window never get repainted anymore.
It does not seem to be in an infinite loop since my CPU-meter is at 0%.

/var/log/messages does not say anything interesting, just some connects and
disconnects. When I kill Mozilla, /var/log/messages says:
Feb 24 16:44:57 p300 Xprt_33: Freeing resource id=40400000 which isn't there.

BTW: The printed page looks great! :-)

Reproducible: Always

Steps to Reproduce:
1. Open a webpage
2. Print the page or open and close print preview


Actual Results:  
The page gets printed and then... Lockup!

Expected Results:  
No lockup

I run Mozilla 1.3b and xprint 007 from RPM on a RedHat 7.1 system.

Updated

15 years ago
Keywords: hang
(Reporter)

Comment 1

15 years ago
Update:

The printing progress bar _does_ disappear, but since Mozilla hangs, the image
of it remains in the browser window.

Today the CPU-meter went to ~100% when Mozilla hung.

In /var/log/messages, the last disconnect doesn't appear until I kill Mozilla.

When restarting, Mozilla wanted me to create a talkback. ID TB17480960Y.

Comment 2

15 years ago
smontagu:
Can you try to fetch the stack trace from "TB17480960Y", please ?
Whiteboard: Need stacktrace from talkback TB17480960Y

Updated

15 years ago
Keywords: stackwanted
Created attachment 115581 [details]
Talkback stack

Comment 4

15 years ago
Looking at
-- snip --
libc.so.6 + 0x8169c (0x4045b69c)
libc.so.6 + 0x813f4 (0x4045b3f4)
nsFontMetricsXlibContext::~nsFontMetricsXlibContext()
[/builds/client/linux22/seamonkey/mozilla/gfx/src/xprint/nsFontMetricsXlib.cpp,
line 1033]
DeleteFontMetricsXlibContext()
[/builds/client/linux22/seamonkey/mozilla/gfx/src/xprint/nsFontMetricsXlib.cpp,
line 1068]
nsDeviceContextXp::DestroyXPContext()
[/builds/client/linux22/seamonkey/mozilla/gfx/src/xprint/nsDeviceContextXP.cpp,
line 319]
nsDeviceContextXp::EndDocument()
[/builds/client/linux22/seamonkey/mozilla/gfx/src/xprint/nsDeviceContextXP.cpp,
line 336]
-- snip --
this is definately bug 193081 ("Mozilla locks up when percent complete hits 100%
when printing via Xprint").

Marking bug as DUPlicate of bug 193081 - this should already be fixed in both
1.3final branch and "trunk" ...

*** This bug has been marked as a duplicate of 193081 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.