Form is submitted improperly and yahoo takes you to an error page

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Jason Oppel, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Using Build 1999111520 on a P233MMX w/64MB RAM when visiting
http://tv.yahoo.com/yahoo/register/cableproviders.dpg?zipcode=27040
I had the following problem:

When the "Go" button is clicked beside the drop down box that reads "NC, Rural
Hall - Time Warner" then you are taken to an error page which reads...

Error!

The channel you have entered, !No Ne! is not found. Click "Next" to try again.
When the go button is clicked in this case you should be taken to local TV
listings. This error occurs no matter what area code you're trying to get TV
listings for. This form works perfectly in Netscape 4.7. You can check other
area codes to make sure they're working by simply replacing the part of the URL
that reads zipcode=27040 with zipcode=desiredzip The offending peice of code
 apparently is: <!-- Get a list of Channel Areas for this zipode --><form
  method=post action="http://tv.yahoo.com/yahoo/register/congrats.dpg"><tr><td
     bgcolor="#ffffcc" align=right><font face=arial><b>Cable
  Listings:</b></font></td><td bgcolor="#dcdcdc"><font size="-1" face=arial>Select
  one of the following cable companies: <br><select name=chanArea><OPTION
 VALUE="NC32428">NC, WINSTON SALEM - TIME WARNER </select><input type=submit
    value="GO"></font></td></tr></form>

    <!-- Get a list of Channel Areas for this zipode -->
    <form method=post action="http://tv.yahoo.com/yahoo/register/congrats.dpg">
    <tr>
        <td bgcolor="#ffffcc" align=right>
	<font face=arial>
	<b>Cable Listings:</b>
	</font>
	</td>
        <td bgcolor="#dcdcdc">
	<font size="-1" face=arial>
	Select one of the following cable companies: <br>
        <select name=chanArea>

<OPTION VALUE="NC32428">NC, WINSTON SALEM - TIME WARNER </select>
        <input type=submit value="GO">
	</font>
        </td>
    </tr>
    </form>

Updated

18 years ago
Assignee: karnaze → pollmann

Comment 1

18 years ago
Reassigning to Eric.
(Assignee)

Comment 2

18 years ago
The value that appears to be submitted incorrectly here is a select.  I was able
to reproduce the bug the first time I ran this with my build, but now I can't
reproduce it anymore.  Therefore, I can't trace down what's going wrong.  I'll
try a few more times.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

18 years ago
Tried Windows, Linux, various zip codes.  I couldn't reproduce this one.  Can
you come up with a reproducable test case?  Note that if you use the forward and
back buttons to navigate, the form data won't be reposted correctly and you will
get this error.  This forward/back bug is bug 17685

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
As an aside, a fix for this will be checked in to an early M13 build (see the
other bug).
You need to log in before you can comment on or make changes to this bug.