Bugzilla requires Javascript for proper operations when searching for existing bugs

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Barry Treahy, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

For the bugzilla query to work and report back existing bugs properly, based on
the selection criteria, it seems to need Javascript enabled.  That is fine but
if it is not enabled, Bugzilla should earlier stop you and require that it is
enabled, or be smart enough to operate without it...

Reproducible: Always

Steps to Reproduce:
1. Disable Javascript
2. Query based on specific search criteria
3.

Actual Results:  
With JS off, the results are incorrect and generally returns zarro!
With JS on, the results are proper and this helps to avoid duplicate bug filings
for folks like me who couldn't find a hit simply because my JS was disabled...

Expected Results:  
Either stop the transaction and require JS to be enabled or fix the query so
that it can operate without JS.
The query works fine if you pick components, versions, and targets that actually
belong in the product(s) you've chosen.  The javascript assists in preventing
you from chosing ones that won't match, but having all of the choices still
available is essential to allow it to work without javascript.  The catch is to
use it without javascript requires that you know which components belong to
which products.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.