Recent regression: margin-left doesn't work with : first-line

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Marc Boullet, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
The following testcase works fine in Mozilla 20030220.
It is broken in Phoenix 20030223 (hope it is broken in Mozilla too).

What I expect is the second, .., nth lines to be aligned with the first
character of the first line thus the margin-left: -1.4ex which represents the
width of the
:before.
(Reporter)

Comment 1

15 years ago
Created attachment 115476 [details]
testcase

Comment 2

15 years ago
*** Bug 194853 has been marked as a duplicate of this bug. ***
But 'margin' doesn't apply to :first-line according to the spec. See bug 103189.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Verified invalid.  Sounds like what you _really_ want is a negative text-indent...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.