If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[DOGFOOD]missing characters over HTTP

VERIFIED DUPLICATE of bug 19337

Status

()

Core
Networking
P1
critical
VERIFIED DUPLICATE of bug 19337
18 years ago
18 years ago

People

(Reporter: dbaron, Assigned: Judson Valeski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

DESCRIPTION:  I'm seeing missing characters over HTTP on both text/html and
text/plain files.  It looks like one character at the edge of each packet is
being dropped.

This seems to be a recent regression.  In addition to missing characters, it
causes some other strange problems.  For example, on the new bug form that I'm
filling out now, the OS field is very wide because one of the options is
'Mac System 7.6.1OPTION VALUE="Mac System 8.0">Mac System 8.0'.


STEPS TO
EPRODUCE:

 * load attached test case


ACTUAL RESULTS:

 * some lines are one character too short


EXPECTED RESULTS:

 * they should all be the same length


DOES NOT WORK CORRECTLY ON:
 * Linux,
apprunner, 1999-10-20-08-M12
Created attachment 2986 [details]
test case described in bug (text/plain)
Priority: P3 → P1
Summary: missing characters over HTTP → [DOGFOOD]missing characters over HTTP
This causes (not too surprisingly) strange and erratic problems on web pages all
over the place.  Losing a character of markup can have very strange effects.
(I'd say it causes obvious problems (many of which make the page unusable) on
about 1 out of 25 to 50 pages, as a rough guess.)  For example, it caused
misaligned table cells on an LXR diff so that the entire page was off to the
right of the screen (since the "<" of a "<TD>" was lost).  I've also seen it
show up on bugzilla forms two or three different times.

Making P1 and marking as DOGFOOD.

Updated

18 years ago
Whiteboard: [PDT+]

Comment 3

18 years ago
Putting on the PDT+ radar.

Updated

18 years ago
Assignee: gagan → valeski

Comment 4

18 years ago
This looks bad... I can't verify/test this where I am but considering the
urgency of this bug am assigning it to valeski. CC'ing warren, in case he has
seen anything like that...
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago
*** This bug has been marked as a duplicate of 19337 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
Marking VERIFIED DUPLICATE.

Comment 7

18 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.