trunk topcrash [@ js_strlen]

RESOLVED FIXED

Status

MailNews Core
Backend
--
critical
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Jan Carpenter, Assigned: Scott MacGregor)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
Source File : /builds/client/linux22/seamonkey/mozilla/js/src/jsstr.c line : 2727

Build Id List 
2003022305
2003022408

 Stack trace(Frame) 

	 js_strlen()	[/builds/client/linux22/seamonkey/mozilla/js/src/jsstr.c  line 2727] 
	 js_NewStringCopyZ()	[/builds/client/linux22/seamonkey/mozilla/js/src/jsstr.c 
line 2566] 
	 JS_NewUCStringCopyZ()	[/builds/client/linux22/seamonkey/mozilla/js/src/jsapi.c
 line 3580] 
	 XPCConvert::NativeData2JS()
[/builds/client/linux22/seamonkey/mozilla/js/src/xpconnect/src/xpcconvert.cpp 
line 377] 
	 XPCConvert::NativeArray2JS()
[/builds/client/linux22/seamonkey/mozilla/js/src/xpconnect/src/xpcconvert.cpp 
line 1609] 
	 nsXPCWrappedJSClass::CallMethod()
[/builds/client/linux22/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp
 line 1074] 
	 nsXPCWrappedJS::CallMethod()
[/builds/client/linux22/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp
 line 428] 
	 PrepareAndDispatch()
[/builds/client/linux22/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp
 line 100] 
	 nsMimeHtmlDisplayEmitter::WriteHTMLHeaders()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/emitters/src/nsMimeHtmlEmitter.cpp
 line 232] 
	 nsMimeHtmlDisplayEmitter::EndHeader()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/emitters/src/nsMimeHtmlEmitter.cpp
 line 335] 
	 mimeEmitterEndHeader()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimemoz2.cpp  line
1887] 
	 MimeMessage_write_headers_html()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimemsg.cpp  line 794] 
	 MimeMessage_close_headers()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimemsg.cpp  line 433] 
	 MimeMessage_parse_line()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimemsg.cpp  line 282] 
	 convert_and_send_buffer()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimebuf.cpp  line 169] 
	 mime_LineBuffer()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimebuf.cpp  line 256] 
	 MimeObject_parse_buffer()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimeobj.cpp  line 260] 
	 mime_display_stream_write()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/mimemoz2.cpp  line 899] 
	 nsStreamConverter::OnDataAvailable()
[/builds/client/linux22/seamonkey/mozilla/mailnews/mime/src/nsStreamConverter.cpp
 line 949] 
	 nsDocumentOpenInfo::OnDataAvailable()
[/builds/client/linux22/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 243] 
	 nsStreamListenerTee::OnDataAvailable()
[/builds/client/linux22/seamonkey/mozilla/netwerk/base/src/nsStreamListenerTee.cpp
 line 97] 
	 nsOnDataAvailableEvent0::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp
 line 432] 
	 nsStreamListenerEvent0::HandlePLEvent()
[/builds/client/linux22/seamonkey/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp
 line 113] 
	 PL_HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/xpcom/threads/plevent.c  line 663] 
	 PL_ProcessPendingEvents()
[/builds/client/linux22/seamonkey/mozilla/xpcom/threads/plevent.c  line 595] 
	 nsEventQueueImpl::ProcessPendingEvents()
[/builds/client/linux22/seamonkey/mozilla/xpcom/threads/nsEventQueue.cpp  line 391] 
	 event_processor_callback()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp  line 200] 
	 our_gdk_io_invoke()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp  line 79] 
	 libglib-1.2.so.0 + 0x10b76 (0x402c4b76)  
	 libglib-1.2.so.0 + 0x137de (0x402c77de)  
	 libglib-1.2.so.0 + 0x13569 (0x402c7569)  
	 libglib-1.2.so.0 + 0x12534 (0x402c6534)  
	 libgtk-1.2.so.0 + 0xa83ff (0x401c13ff)  
	 nsAppShell::Run()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp  line 348] 
	 nsAppShellService::Run()
[/builds/client/linux22/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 480] 
	 main1()
[/builds/client/linux22/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line
1651] 
	 main()
[/builds/client/linux22/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line
1636] 
	 libc.so.6 + 0x159c4 (0x404539c4)   



COMMENTS/URLS:
Incident   Build       Comment
17486775  l2003022408  Running navigator and mail, first time after changing my
locale to zh_TW. Mozilla crashed before I was able to type in my account info to
access my email. 	59151 	59151
17483973  l2003022305  
17474505  l2003022305  Reading mail 
17473945  l2003022305  
17450841  l2003022305  checking mail 
17450472  l2003022305  Checking email
17450015  l2003022305  clicked on email to read it. date column was empty
17448661  l2003022305  
17443656  l2003022305  Opening an email with an attachment 	
17441316  l2003022305  
17441081  l2003022305  switching between mail msgs 	
17438993  l2003022305  
17438218  l2003022305  Trying to view a specific IMAP message. This is a
regression. 
17431886  l2003022305
17429447  l2003022305
(Assignee)

Comment 1

15 years ago
putting on seth's radar too.

Updated

15 years ago
Severity: normal → critical

Comment 3

15 years ago
Yup...looks like a dup.  But instead of marking it so, just gonna mark it fixed
so we know this crash bug is gone.

Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
*** Bug 194734 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ js_strlen]
You need to log in before you can comment on or make changes to this bug.