Download Manager prefs should be accessible from DLM dialog

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
--
enhancement
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: selmer (gone), Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Given the disparity of tastes in handling the DLM dialogs, perhaps it makes
sense to allow switching directly from the dialogs rather than detouring through
prefs.
Why?  This should be something a user sets exactly once, no?  Why does it need
to appear as an option on every file save?
(Reporter)

Comment 2

16 years ago
Heh.  Maybe I'm just jaded because it won't remember my preference most of the
time ;-)

Seriously, non-developer users have trouble working with prefs and it seems like
more applications these days that move preferences like this out to the context
in which they occur.  This would probably have to be part of a general push to
make preference setting more approachable for the masses.

Comment 3

16 years ago
The download dialogs already take up a hefty amount of screen real estate.  Low
resolution displays are especially sensitive to this.  I think we should hold
the line against bloating these dialogs any further.
Product: Browser → Seamonkey
Assignee: bross2 → download-manager
QA Contact: chrispetersen

Comment 4

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 5

9 years ago
Edit > Preferences will get you there in SeaMonkey 2.0 Beta 1 and later, where the download manager has a full menu bar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.