title bar isn't updated when clicking "about:*" tab

RESOLVED DUPLICATE of bug 195833

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 195833
15 years ago
9 years ago

People

(Reporter: Koike Kazuhiko, Assigned: jag (Peter Annema))

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Window title bar isn't updated when clicking "about:*" tab.

(1) Load "about:" in a tab.
(2) Click an another tab, and click "about:" tab again.

Actual result: The window title bar isn't updated.

Expected result: The window title bar should be "about:".


Build: 2003022508-trunk/Linux
Neil: is the fix from bug 105842 broken ?

Comment 2

15 years ago
Regression caused by bug 176624.

Component returned failure code NS_ERROR_FAILURE (nsIURI.hostPort) ...
Keywords: regression
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3) Gecko/20030312]


Reply to Description:

Confirmed:
 *'about' and 'about:config' leave the title of the previous active tab :-(
 *But 'about:blank' does update the title with "Mozilla" :-)

You can change OS from 'Linux' to 'All'.


Addition to comment 2:

I think that this bug appeared after v1.3a and before v1.3 !?

The full JS Error is
[
Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
 location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js ::
anonymous :: line 350"  data: no]
Source File: chrome://navigator/content/nsBrowserStatusHandler.js
Line: 350
]

At least "NS_ERROR_FAILURE" should be added to the Summary to give more
visibility to this bug.
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

Bug seems fixed somehow. (with v1.3 profile, at least)

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 195833 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.