Blank between quotation mark and text is dropped

RESOLVED DUPLICATE of bug 200854

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 200854
15 years ago
9 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Blank between quotation mark and text is dropped
if the quotation is nested and the message is in
CJK coding.

**********************
On 02/22/2003 06:29 AM, Koike Kazuhiko wrote:
> abc
def
**********************

This plain text message is quoted as follows:
**********************
On 02/22/2003 06:35 AM, Koike Kazuhiko wrote:
> On 02/22/2003 06:29 AM, Koike Kazuhiko wrote:
> 
>>abc
> 
> def
**********************

A blank before "abc" is dropped.

Build: 2003022508-trunk/Linux

Related bug: bug 144998
(Reporter)

Comment 1

15 years ago
Created attachment 123564 [details] [diff] [review]
patch v1

The current code doesn't append a blank at all
if format=flowed isn't specified in Content-Type.

With my patch a blank is appended even if the current line
is empty. But that's better than current behaviour.
(Reporter)

Comment 2

15 years ago
Comment on attachment 123564 [details] [diff] [review]
patch v1

The current code is checked in by Ben Bucksch to fix bug 58377.
Attachment #123564 - Flags: review?(ben.bucksch)

Comment 3

15 years ago
Comment on attachment 123564 [details] [diff] [review]
patch v1

You must have seen the comment you removed, which says that I *intentionally*
didn't add a space there to prevent bugs. I read the spec (RFC2646, 4.2, 2.
paragraph) and it clearly says that such a line (consisting only of quote marks
and a single space) should *not* flow, so my comment in the source is void. But
did you at least test what happens with format=flowed? With your fix, does the
code output a space for empty lines? If so, does Mozilla correctly display the
empty line?

Assuming yes, r=BenB.
Attachment #123564 - Flags: review?(ben.bucksch) → review+
(Reporter)

Comment 4

15 years ago
I couldn't understand your comment. But Mozilla seems to work
well with my patch.

***********************
On 05/16/2003 08:46 AM, Koike Kazuhiko wrote:
> 111

222
***********************

This mail is quoted as the following.

***********************
On 05/17/2003 02:13 PM, Koike Kazuhiko wrote:
> On 05/16/2003 08:46 AM, Koike Kazuhiko wrote:
>> 111
> 
> 222
***********************

The empty line above "222" is quoted with a blank.

Comment 5

14 years ago
Note that "CJK coding" is not required to see this bug; I see the same result 
for plain old Western encoding:  The leading space is stripped from nested 
quotes, when the plain-text message being replied to is not f=f.

This problem is similar to bug 200854.

Koike wrote (comment 4):
> I couldn't understand your comment.

1) Apply your patch.
2) Reply to a non-ff message with a quoted empty line, such as:
=====
> abc def
>
> ghi jkl

message body
=====
With your patch, the message should be:
=====
>> abc def
>>                           <- trailing space here
>> ghi jkl
>                            <- trailing space here??
> message body

reply body
=====

3) Send this message with format=flowed.  How does the reply look?  If your 
patch exhibits the problem Ben suspects, the message will look like this (with 
the vertical bars (|) indicating the continuous change-bar):
=====
|| abc def
|| ghi jkl
|
| message body

reply body
=====

If that happens (no empty line between the first and second lines), then you 
need to suppress that trailing space on the empty quoted line.  See also bug 
165077.
Product: MailNews → Core

Comment 6

13 years ago
If I'm not mistaken, the symptom of this bug, like the symptom of bug 200854, is 
no longer occurring with trunk builds; probably part of the fix to bug 144998.

Koike Kazuhiko, can you confirm?
This is actually a dupe of bug 200854. I'll dupe this against that bug. See my
explanation there for what was wrong with the code and what the fix was.

*** This bug has been marked as a duplicate of 200854 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.