Nested content of HTML message not shown in "view message as simple html" mode

VERIFIED FIXED in mozilla1.4alpha

Status

MailNews Core
MIME
P2
normal
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: kaie, Assigned: harishd)

Tracking

({regression})

Trunk
mozilla1.4alpha
regression
Bug Flags:
blocking1.4a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
This is a regression.
Mozilla 1.0.1 works fine.
Mozilla 1.2.1 works fine.
My own archived test build, Mozilla 1.2.1 with patches from bug 161488 and bug
179082 works fine, too.

The first build I still have around and that does no longer work is from 2003-01-29.
Latest nightlies don't work either.
The recent fixes for bug 189988, bug 194636, bug 188344 seem to be unrelated, I
have tested to back them out, still doesn't work.
(Reporter)

Comment 1

15 years ago
Being more specific, my test case looks like:

encrypted message, contains
  body text
  message forwarded inline
    headers of forwarded message
    body of forwarded message
    another message forwarded inline
      headers of forwarded message
      body of forwarded message       <<< problem

The last portion is not displayed with recent builds.
It shows up fine in older builds, as explained above.

Unfortunately I can not attach the testcase, the contents are encrypted for good
reason :-)
(Reporter)

Comment 2

15 years ago
1.3 is broken, too, so the regression was introduced between the dates when we
branched for 1.2 (2002-11-05) and the release of 1.3a (2002-12-13).

I suppose it is likely that the regression is below mailnews/mime.
There were a lot of checkins between those dates, unfortunately.

While we no longer have mozilla builds from that timespan archived on ftp.m.o,
we do still have commercial nightly builds available. I will try a binary search
using those builds, I think that's easier than backing out all the potential
patches.
(Reporter)

Comment 3

15 years ago
After a lot of testing I found:

2002-11-19 is the latest build that is able to display my message correctly

2002-11-20 and all builds after are broken
(Reporter)

Comment 4

15 years ago
Created attachment 115613 [details]
Testcase mailbox, copy to your local mail folders directory

I was able to contents of the encrypted message.
It is an HTML message.
I replaced all text contained in the message with dummy text, but I did not
change any part of the message structure. At the end of the message I added
some indicator text, saying "THIS IS NOT SHOWN".

This attachment is a mail message box file. Copy it to your profile,
subdirectory "Mail/Local Folders".

Use a build up to Mozilla 1.2.1 and open the message.
You'll see the text "THIS IS NOT SHOWN..."

Use a more recent build, for example the latest nightly.
You'll NOT see the text "THIS IS NOT SHOWN".


Expected behaviour: All text should be shown with the latest version of
Mozilla.
(Reporter)

Updated

15 years ago
Summary: Nested content of encrypted message not shown → Nested content of HTML message not shown
I have a fresh Win2K build, built from scratch yesterday 2003-02-25, and I
just cannot reproduce this bug with the testcase attached. I see perfectly
well the lines commented "LINES NOT SHOWN".
And I use a different profile, so no profile corruption is possible here

==> WFM ?
(Reporter)

Comment 6

15 years ago
I just found out that you'll only see this bug when using the option:
mail window/view/message body as/simple html

So it seems, a checkin on that date has broken the simple html translation, the
build from 2002-11-19 alraedy has the "view as simple" option, and it does
display correctly.
(Reporter)

Updated

15 years ago
Summary: Nested content of HTML message not shown → Nested content of HTML message not shown in "view message as simple html" mode
Ok, I confirm the bug with that option.
If I use Document Inspector to see the style rules applied to the corresponding
nodes, I don't even see the nodes there. They are not here. So I don't think
my Resizing checkin can be guilty for that since it's totally unable to remove
elements from the tree like that...
Marking as blocking 1.4a.  Arnold says: "Regressions will not be tolerated."
Flags: blocking1.4a+

Comment 9

15 years ago
The parser landing (parser node lifespan shortening) that day could be the
culprit. It was quite major and caused some regressions which were quickly
fixed. This one might have gone unnoticed. 

CC:ing Harish who did the work and Ben who knows Simple HTML better than most.
(Reporter)

Comment 10

15 years ago
Over to Harish, who agrees this problem might have been introduced with the
parser node optimization checkin. Thanks for looking!
Assignee: kaie → harishd
(Assignee)

Updated

15 years ago
Priority: -- → P2
Target Milestone: --- → mozilla1.4alpha
(Assignee)

Comment 11

15 years ago
I uncommented line 168 ( printf("%s",
NS_LossyConvertUCS2toASCII(aString).get()); ), in mozSanitizingSerializer.cpp,
and _did_see_ the complete message on the standard output!  
(Reporter)

Comment 12

15 years ago
Created attachment 116885 [details]
HTML page test case

Harish, thanks for this update.
With this hint I produced a HTML output file, which is the contents that are
being given to the layout engine (?) for display.

I am attaching a HTML file that contains sections which are not displayed,
neither in mail, nor in navigator window.

It seems the problem is being caused by funky <title> tags.

When looking at the attached HTML with the latest Mozilla, the NOT SHOWN
content is not shown.

When looking at the attached HTML with Mozilla 1.0x, the NOT SHOWN content is
shown in the title bar.
(Assignee)

Comment 13

15 years ago
It's bug 182021 that has caused this regression. 
(Reporter)

Comment 14

15 years ago
Created attachment 116901 [details] [diff] [review]
Patch v1

This change was suggested by Harish.
(Reporter)

Comment 15

15 years ago
Comment on attachment 116901 [details] [diff] [review]
Patch v1

The patch fixes the problem for me.

Harish, can you please review?
Attachment #116901 - Flags: review?(harishd)
(Assignee)

Comment 16

15 years ago
Comment on attachment 116901 [details] [diff] [review]
Patch v1

r=harishd
Attachment #116901 - Flags: review?(harishd) → review+
(Assignee)

Comment 17

15 years ago
Comment on attachment 116901 [details] [diff] [review]
Patch v1

Note: One thing that the patch does not address is handling of attributes in
the title tag. Honestly, I hate myself for making this suggestion ( of writing
out <title> and </title> ), however, this is the simplest patch with almost no
risk. I can come up with a different patch, if need be, but unfortunately I
don't have the time for it right now.
(Assignee)

Comment 18

15 years ago
On the other hand, I'll feel much better if I can fix this the right way. Will
try to find some time :-/
Status: NEW → ASSIGNED

Updated

14 years ago
Flags: blocking1.4a+ → blocking1.4a-
(Reporter)

Comment 19

14 years ago
Nominating as a blocker. This is a regression and we have a fix.

Harish, I think we should check in the workaround until you have time to work on
a better fix?
Flags: blocking1.4b?
Keywords: nsbeta1
(Reporter)

Comment 20

14 years ago
Comment on attachment 116901 [details] [diff] [review]
Patch v1

Peter, can you please review?
Attachment #116901 - Flags: superreview?(peterv)
Attachment #116901 - Flags: superreview?(peterv) → superreview+
(Assignee)

Comment 21

14 years ago
Fix landed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
clearing request, since this has landed.
Flags: blocking1.4b?

Comment 23

14 years ago
Trunk build 2003-04-24: Mac 10.1.5
Trunk build 2003-04-23: WinXP
Verified Fixed.
Status: RESOLVED → VERIFIED
QA Contact: stephend → nbaca
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.