will not start after upgrade from 1.2.1 to 1.3b: 'invalid page fault in module JSDOM.DLL'

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
--
blocker
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: lupin0, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Q312461)
Build Identifier: 1.3.0.2003021008 

I am using win98 (sp1)
I first installed 1.0 (complete), then 1.2.1 (complete), then 1.3b (complete).
Afterwards mozilla would not open.
I repeated the steps listed below four(4) times with the same results.
Add/remove programs shows mozilla 1.2.1 is installed, NOT 1.3b.


Reproducible: Always

Steps to Reproduce:
1: run mozilla-win32-1.0 installer (1.0.0.2002053015), mozilla opens. do not 
close mozilla.
2: run mozilla-win32-1.2.1 installer (1.2.1.2002113012), click 'OK' when asked 
to close mozilla for upgrade, mozilla opens. do not close mozilla.
3: run mozilla-win32-1.3b instalelr (1.3.0.2003021008), click 'OK' when asked 
to close mozilla for upgrade, click 'ok' when asked to restart computer.
5: after restart, open mozilla.
Actual Results:  
after restarting I opened mozilla and received this illegal operation error:

MOZILLA caused an invalid page fault in
module JSDOM.DLL at 0177:6146a463.
Registers:
EAX=00000004 CS=0177 EIP=6146a463 EFLGS=00010202
EBX=00000000 SS=017f ESP=0064f6cc EBP=0064f704
ECX=0064f6f8 DS=017f ESI=00000000 FS=0f57
EDX=0064f618 ES=017f EDI=007bf86c GS=0000
Bytes at CS:EIP:
8b 08 ff 74 24 14 50 ff 51 0c c2 10 00 8b 44 24 
Stack dump:
007bcd34 00000001 00000000 6147910e 00000000 0064f6f8 007bcd34 00000001 
007bd0e4 007bd024 00000000 61e3c2d0 61488948 61488950 0064f740 614795a3 

netscape quality feedback popped up. I reported what happened.


Expected Results:  
after the restart mozilla should have opened normally without errors.
(Reporter)

Comment 1

16 years ago
Step 1 is not needed to reproduce this bug (lupin0@hotmail.com).

Comment 2

16 years ago
remove mozilla directory before upgrade.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
INVALID is not appropriate, we want people to be able to upgrade in place from
milestone to milestone. Nightlies are another story, installing in place is
often broken and it's unwise to expect it to work.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I suspect this is a dupe of a bug Sean recently fixed, try in a recent 1.3 build.
Assignee: dveditz → ssu

Comment 5

15 years ago
Since we are now into the beta stage of 1.5, is this bug relevant anymore?  Or
can it be closed with WONTFIX?

Comment 6

15 years ago
No response -> WFM

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.