Orientation with arrow-keys doesn't work on wrapped lines

RESOLVED WORKSFORME

Status

()

Core
Selection
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Tomas Pihl, Assigned: mjudge)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: editorbase+)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3b) Gecko/20030211

When composing a mail, I noticed I'm unable to walk around in the text with the
arrow-keys. This only happens with wrapped lines.

Line  Text
----  ----
1     Long line which after 78 chars will
2     wrap to the second line.
3
4     Beginning of a new line

If I place the cursor at column 1 at line 1 I'm able to move forward with the ->
key. However, if I place the cursor at column 1 on the second line, pressing the
-> key will result in the cursor ends up at column 1 on line 3. Pressing the <-
key doesn't result in anything.

Reproducible: Always

Steps to Reproduce:
1. See above




Also tried this on 1.3b WinXP. There everything worked ok.

Comment 1

15 years ago
plain text mail or  html mail compose?
You build date is 2/11, have you tried a more recent build (except 2/24)?

sounds like a bug for Browser | Selection
(Reporter)

Comment 2

15 years ago
Plain text mail. I haven't tried any later builds.
(Reporter)

Comment 3

15 years ago
I've now tried Build ID: 2003022510 and I'm still having the problem. This on an
Ultra-10 running Solaris 8.

Hmm, I just noticed I'm having the problem in this "Additional Comments" window
as well. This is then not a Mail/News problem, rather something else as brade
mentioned. I played around a bit and it only happens on wrapped lines thus
navigating forward/backwards will have the cursor jump abound on the wrapped
line in a really weired way. As soon as insert RETURNs in the end of each line
of the wrapped line (ie, prior to where each wrap occures (hope you understood
that)), the bug goes away.

Are the fonts used involved here in some way? I'll add the font spec I'm using
if it helps. Western fonts:

Prop       Serif (adobe-times-iso8859-1) Size 12
Monospace  adobe-courier-iso8859-1       Size 12
Minimum font size: 12
Allow documents to use other fonts: Yes

Comment 4

15 years ago
duplicate of bug 194774? probably not due to original problem reported in much
earlier build?

-->selection
Assignee: sspitzer → mjudge
Component: Mail Window Front End → Selection
Keywords: nsbeta1
Product: MailNews → Browser
QA Contact: esther → pmac
Whiteboard: editorbase
pmac: Can you confirm whether this is a problem in current builds? Thanks!

Updated

15 years ago
Whiteboard: editorbase → editorbase+
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 7

12 years ago
Unable to reproduce this bug following the reporter's original instructions
using Thunderbird 1.5 beta1

Marking worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 8

12 years ago
Oh! I am sorry! I failed to notice that this is a SunOS-specific bug. I was
testing on Mac OS X re-opening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

10 years ago
I couldn't reproduce this on Solaris 11 with thunderbird 3.0a2pre(2008061703).

Comment 10

10 years ago
Mark WORKSFORME on behalf of Xin Sun. Thanks! 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.