Inconsistent HTML rendering (Mozilla 1.3a vs 1.2.1)

RESOLVED DUPLICATE of bug 194014

Status

()

Core
Layout
--
trivial
RESOLVED DUPLICATE of bug 194014
15 years ago
5 years ago

People

(Reporter: Ruud, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

Please view URL in the latest Mozilla build (1.3b) and in the latest official
version (1.2.1) and notice the difference in the menu on the lefthand side. 1.3b
seems to add arbitrary <br> tags.

This also occurs in the latest PC build.

Reproducible: Always

Steps to Reproduce:
1. Go to http://ip30.eti.uva.nl/ember/ch1_info.php
2. Check menu in v1.3b and 1.2.1
Actual Results:  
Incorrect display of menu

Expected Results:  
Display menu as in 1.2.1
(Reporter)

Comment 1

15 years ago
Created attachment 115634 [details]
Menu in 1.3b
(Reporter)

Comment 2

15 years ago
Created attachment 115635 [details]
Menu in 1.2.1

Comment 3

15 years ago
The block the nav heading is in is too narrow causing word wrap. Cursory glance
at the source shows "Table of Contents" is in a table cell in a table and
neither have a width set via html or css. Setting a width would fix the wrapping
but I didn't spend enough time looking at the code to know why the table wants
to shrink that small.

Comment 4

15 years ago
Created attachment 115641 [details]
simplified testcase

it's absolutely positioned div that forces the table to shrink.

Comment 5

15 years ago
Created attachment 115642 [details]
simplified testcase 2

a better testcase showing the diff between relatively and absolutely positioned
divs.
Attachment #115641 - Attachment is obsolete: true

Comment 6

15 years ago
Created attachment 115643 [details]
workaround

after looking more at this...
i believe the width of absolutely positioned div is calculated like this
width = width of first td + computed width of second td = 15 + x

while it is supposed to be
width = computed width of first td + computed width of second td = 16 + x

that is, the given width of first td is 15. although, really it is 16 due to
the image width being 16px

Comment 7

15 years ago
it's probably a dupe of bug 194014

Comment 8

15 years ago
Yep, comment 7 is right.

*** This bug has been marked as a duplicate of 194014 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
indeed backing out the patch for bug 97777 fixes this.
You need to log in before you can comment on or make changes to this bug.