DOM assign of tHead -> not correcly positioned

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Daniel van der Zee, Assigned: vidur (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
(See attached test case)

When setting a tHead the header doesn't get added to the top of the table but to
the bottom. The problem is in
   nsHTMLTableElement::SetTHead

It calls AppendChild instead of inserting it before the first child with
insertBefore.
(Reporter)

Comment 1

18 years ago
Created attachment 2990 [details]
Test case
(Reporter)

Updated

18 years ago
Depends on: 9213
(Reporter)

Comment 2

18 years ago
Test case depends on fixing 9213 (tHead property get) first.
cc:ing karnaze.  This looks like it's really a tables bug.
(Assignee)

Comment 4

18 years ago
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.
(Assignee)

Comment 5

18 years ago
Just saw this while scanning my bug list. Fixed it last week.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
Verified with 2000-02-02-14.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.